Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Help I messed up Yast and rpm somehow

From: "Carl E. Hartung" <suselinux@xxxxxxxxxxxxx>

david rankin wrote:
<snip>
| Several months ago, I installed samba 3.0.7 on my 9.0 box. I probably
| did an rpm -Uvh. Now rpm thinks I have 2.2.8a and 3.0.7 installed. Is
| there a way to fix this?
<snip>
| Needless to say Yast is not happy from a dependency standpoint.
<snip>

Hi David,

I'd be surprised if you introduced an inconsistency into your rpm
database with -Uhv. That's the mode that a) removes the older and
installs the newer package in the case of an upgrade, and b) installs it
as new if an earlier version isn't found on the system. You're more
likely to introduce dependency conflicts using --force, which say's to
rpm "To heck with it! I want it installed now!"

Also, don't confuse the YaST2 gui configuration utilities with the
underlying programs. In this case, there's a) the samba client package
and b) the YaST2 module designed to help you configure that client
package. I don't have any dependency issues on this system and here's
my output:

Well, that is the problem. When I go into yast2, it complains that
yast2-samba-client-2.8.10-3 needs samba-client-2.2.8a. I have
samba3-client-3.0.7-1 installed. samba-client-2.2.8a was removed by the
rpm-Uvh but yast doesn't understand that. The yast2-samba-client package
wasn't removed because there was no corresponding 3.0.7 package buit. When I
go to install new packages via yast it always complains about this and gives
me fits when I try to install some other unrelated package. I don't know if
it makes a difference, but I'm running yast2 via the command line over an
SSH connection. Is there some kind of rpmdb --rebuild that can straighten
the yast problem out?

--
David C. Rankin, J.D., P.E.
RANKIN LAW FIRM, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
(936) 715-9333
(936) 715-9339 fax
www.rankinlawfirm.com
--



< Previous Next >