Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Java 1.5 Upgrade on SuSE 9.2 - your experience and how to?
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Sat, 12 Feb 2005 18:50:45 +0100
  • Message-id: <culfll$119$1@xxxxxxxxxxxxxxxx>
George Stoianov wrote:

> Hello everyone,
>
> I was wondering if any of you guys have upgraded to
> JVM 1.5 and what is your experiences so far?

Yes, we've gone to 1.5 - mostly because of Firefox, I believe.
We just got the JRE from sun, installed et voila. No probs whatsoever.

> I am still investigating how to do it so any advice on
> that is greatly appreciated as well,

1. Retrieve the J2SE package from sun, either full or JRE only.
2. Install as e.g. /opt/jre1.5.0/ or whereever you want it.
3. correct the /usr/lib/java symlink to point to your new installation:
/usr/lib/java -> /opt/jre1.5.0/
4. Create optional symlink for java plugin for firefox:
/opt/firefox/plugins/libjavaplugin_oji.so -> /usr/lib/java/plugin/i386/ns7/libjavaplugin_oji.so

Note - this all applies to SuSE 9.0, but I can't really imagine it would work much
different on 9.2.


/Per Jessen, Z├╝rich

--
http://www.spamchek.com/freetrial - sign up for your free 30-day trial now!


< Previous Next >
References