Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] [9.2] mozplugger for Firefox
  • From: Paul Trevethan <plist@xxxxxxxxxxxxxxxx>
  • Date: Mon, 14 Feb 2005 09:13:58 +1100
  • Message-id: <20050214091358.3e04b8df@xxxxxxxxxxxxxxxxxxxxxx>
On Sun, 13 Feb 2005 13:58:17 +0100
Fred <frederic.conrotte@xxxxxxxxx> wrote:

> Le Dimanche 13 Février 2005 13:00, Paul Trevethan a écrit :
> > On Sun, 13 Feb 2005 11:41:15 +0100
> > Fred <frederic.conrotte@xxxxxxxxx> wrote:
> >
> > [.......stuff snipped......]
>
> >
> > FWIW, using Firefox under SuSE v9.2 here and all my plugins get
> > linked to directory "/opt/MozillaFirefox/lib/plugins/" - they all
> > work fine. It does sound like Firefox just can't find them.
>
> Ok, I first installed my Firefox manually by downloading it from
> http://www.mozilla.org/products/firefox/
>
> I desinstalled this version and did an "apt install MozillaFirefox"
>
> Now it's installed like you under /opt/MozillaFirefox/
>
> but the problem is the same, I can't get mozplugger working with it :(
>
> Here is my list of plugins :
>
> linux:/opt/MozillaFirefox/lib/plugins # ll
> lrwxrwxrwx 1 root root 40 Feb 13 13:10 flashplayer.xpt
> -> /usr/lib/browser-plugins/flashplayer.xpt
> lrwxrwxrwx 1 root root 42 Feb 13 13:10 libflashplayer.so
> -> /usr/lib/browser-plugins/libflashplayer.so
> lrwxrwxrwx 1 root root 85 Feb 13 13:10 libjavaplugin_oji.so
> ->
> /usr/lib/jvm/java-1.4.2-sun-1.4.2.06/jre/plugin/i386/ns610-gcc32/libj
> avaplugin_oji.so-rwxr-xr-x 1 root root 17316 Jan 24 15:53
> libnullplugin.so lrwxrwxrwx 1 root root 38 Feb 13 13:10
> mozplugger.so -> /usr/lib/browser-plugins/mozplugger.so
> lrwxrwxrwx 1 root root 33 Feb 13 13:34 nppdf.so
> -> /usr/lib/browser-plugins/nppdf.so
> lrwxrwxrwx 1 root root 36 Feb 13 13:10 nsdejavu.so
> -> /usr/lib/browser-plugins/nsdejavu.so
> linux:/opt/MozillaFirefox/lib/plugins #
>
> Fred
>

Fred,

I am no expert in this field. That all looks ok in terms of location.
The only other suggestions I can offer are:

- check that the files in /usr/lib/browser-plugins that the links point
to actually exist;

- download & use latest version of Mozplugger ( v1.7 from memory). I
think re-installing Mozplugger after Firefox will make it find the
plugins and register their presence anew;

- run about:plugins on url line within Firefox, will tell you if it
finds them; and

- failing all else, it may be a problem in/etc/mozpluggerrc. Once in
there you step outside my knowledge, sorry.

Good luck,
Paul.

< Previous Next >
This Thread
References