Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Cannot upgrade to 9.2
  • From: Marc Chamberlin <marcc@xxxxxxxxxxxxxx>
  • Date: Wed, 16 Feb 2005 17:05:08 -0800
  • Message-id: <4213EDC4.2070000@xxxxxxxxxxxxxx>
Carl E. Hartung wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Marc Chamberlin wrote:
<big snip>
| Thanks for your quick guesses, much appreciated... But still no
| joy... When I tried your first suggestion, to install with the acpi
| disabled, I got to about the same point in the installation process, but
| I did get a different error message in the red dialog box - "Sorry,
| linuxrc crashed at address 0x080cd6e1 Linuxrc has been restarted in
| manual mode" However it did not restart at this point, simply froze up
| again and will not respond to the keyboard or mouse.
|
| As for "manual installation" Yes I have already tried that, as mentioned
| in my first communique... It starts to install some drivers, gets to
| where it is installing the disk drivers and then crashes. See above...
|
| So I am still stumped looking for more suggestions on how to proceed...


Hi Marc,

I think what Ralph is suggesting has merit and you might want to
re-think what's happening...

First, 'manual installation' is just that: "It" will load a few
typically essential modules just to get things started, but -- and here
comes the hard part -- you are responsible for looking at what it has
loaded, removing the modules that aren't applicable (depends on your
h/w), loading the ones that it /does/ need -- and that includes support
for the file systems that aren't loaded by default (reiserfs, for one)
- -- and then moving the installation forward with all of that sorted out.
~ I intuitively suspected when I first saw your post that the machine
must bs experiencing contention between the desired module for your SCSI
adapter and one that's already in memory by the time it's trying to load
- -- so it's critical, IMHO, to get a handle on what's being loaded in
that machine from the very beginning.

HTH & regards,

- - Carl

PS: Will somebody monitoring this thread get back to me and let me know
what my stupid quotes character is today? Please??
I've been learning about text/plain "flowed" and "not flowed"...
dynamically inserted (client-side) quote charactors, trailing spaces
etc. -- all in an effort to whip this #@#!$%%$##@$%!!! e-mail client
into shape.

Thanks!

- --
____________________________________________________________________
C. E. Hartung Business Development & Support Services
http://www.cehartung.com/ carlh@xxxxxxxxxxxxx
Dover Foxcroft, Maine, USA Public Key #0x68396713
Reg. Linux User #350527 http://counter.li.org/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFCE6A7usxgymg5ZxMRAkNBAJ41CjdUTmUVaGz6S8DVYTezapF4ggCdGUCF
FinPv7uz/nVTJgTkvqzla7Q=
=yJTm
-----END PGP SIGNATURE-----

Carl - Again thanks for trying to help, I am a relatively newcomer to Linux so please bear with me as I struggle to understand things. I have poked further at the "Manual Mode" of installation from the SuSE installation CDs and I found a section on loading Boot Modules... I am guessing that this is the thing I am suppose to be using to try an load modules manually? If so, I may be getting out of my league here as there are lots of selections in some of the menus and I have no idea on what to choose from these lists... I am attempting to do some research on the internet but fear this is going to be real slow slogging....

On another front, I have discovered that if I attempt to install using the Safe Mode, and adding a parameter called Manual to the list of boot parameters it appears that we get the same behavior as booting up in Manual Mode alone, but with a bunch of things turned off. (such as ACM ACPI etc...) So I figured that would be a very safe way to try.... I also discovered that one can add a VERBOSE parameter as well to the boot parameters. With that we got a bit more intelligible??? response and I am including it below... Maybe this will be enough of a clue for someone to help me along the path....


In the display from the log of what is happening, we got the following (hope I get this all typed in correctly) -

starting yast....
/bin/sh: line 1: 2767 Segmentation fault /sbin/vgscan > tmp/YaST2.tdir/stp2031_1_S_2>/tmp/YaST2.tdir/stp2031_1_E
/bin/sh: line1: 2769 Segmentation fault /sbin/vgchange -a y >/tmp/YaST2.tdir/stp2031_1_S 2>/tmp/YaST2.tdir/stp2031_1_E
/bin/sh: line1: 2771 Segmentation fault LC_ALL=POSIX /sbin/vgdisplay -v >/tmp/YaST2.tdir/stp2031_1_S 2>&1
/bin/sh: line1: 2773 Segmentation fault /sbin/vgchange -a -n >/tmp/YaST2.tdir/stp2031_1_S 2>&1
/usr/lib/YaST2/bin/YaST2: line 506 2031 Killed y2base "$modulename" $moduleargs qt $y2qt_args
/usr/lib/YaST2/bin/YaST2: line 506 2021 Aborted X $xpseudo -xf86config /etc/X11/XF86Config_31.5k -deferglyphs 16 vt07 2>/dev/tty8 1>&2
/sbin/yast: line 302: 2907 Segmentation fault ps aux>/dev/tty9

followed by a list of processes....

Linuxrc crashed. :-((
Press ENTER to continue.


and the computer is hung at this point requiring a power reboot... One other observation I have is that this crash appears to be time related, in other words it does not appear to matter what modules I manage to get installed during the manual process, but how long it is after YaST starts (after selecting the languages).. So I suspect some process is started up in the background, proceeds along till it crashes bringing down the system with it... Just guessing.... I hope this will be enough info for someone to give me a clue on how to proceed, and remember I am not an expert on Linux, so baby steps please! :-)

Marc Chamberlin...

P.S. Not sure what you were asking about your quote character... I see double quotes " inside your comments, and the vertical bar | used for quoting my previous comments.



< Previous Next >