Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: 9.2 scsi install: sym53c8xx: Unknown parameter `mpar'
  • From: Jim Osborn <jimo@xxxxxxxxxx>
  • Date: Thu, 17 Feb 2005 21:36:05 -0800
  • Message-id: <20050218053605.GA3359@xxxxxxxxxx>
On Thu, Feb 17, 2005 at 10:42:50PM -0500, Carl E. Hartung wrote:
> I did notice this subtle warning near the start:
>
> 4. Memory mapped I/O versus normal I/O
>
> Memory mapped I/O has less latency than normal I/O and is the
> recommended way for doing IO with PCI devices. Memory mapped I/O
> seems to work fine on most hardware configurations, but some poorly
> designed chipsets may break this feature. A configuration option is
> provided for normal I/O to be used but the driver defaults to MMIO.
>
> Have you investigated this and what have you tried, if anything, to
> eliminate it as a possibility?

Thanks for the response, Carl. I haven't tried anything specifically
for that option, but just tried some simple options that seemed like
good starting points; since my problem seemed to report parity errors,
I tried to turn off parity checking and see what happened; I also tried
to turn on verbose reporting, that sort of thing.

So far, I don't seem to be able to enter ANY parameters of ANY sort
in linuxrc for this driver. Even just a simple "verb:2" as the
one-and-only parameter shows:
<3>sym53c8xx: Unknown parameter `verb:2'
in /var/log/boot.msg.

It's as though the driver has been compiled to recognize no options
whatsoever. Very strange.

I can't find any useful-sounding parameters in the scsi_transport_spi
module sources or the scsi mid/low level driver doc, but that doesn't
mean there aren't any, just that I can't seem to find them.

>From the config.gz file that appears in /proc after yast is up and
running, I find these lines, and only these, pertaining to (SYM|NCR)53C8:

#
# SCSI Transport Attributes
#
CONFIG_SCSI_SPI_ATTRS=m
CONFIG_SCSI_FC_ATTRS=m
...
CONFIG_SCSI_SYM53C8XX_2=m
CONFIG_SCSI_SYM53C8XX_DMA_ADDRESSING_MODE=1
CONFIG_SCSI_SYM53C8XX_DEFAULT_TAGS=16
CONFIG_SCSI_SYM53C8XX_MAX_TAGS=64
# CONFIG_SCSI_SYM53C8XX_IOMAPPED is not set

so apparently SuSE 9.2 has only the sym53c8xx_2 driver, as a module,
not the sym53c8xx (without the _2) driver. For comparison, my 2.4.23
kernel has this config:

#
# SCSI low-level drivers
#
# CONFIG_SCSI_SYM53C8XX_2 is not set
# CONFIG_SCSI_NCR53C8XX is not set
CONFIG_SCSI_SYM53C8XX=y
CONFIG_SCSI_NCR53C8XX_DEFAULT_TAGS=4
CONFIG_SCSI_NCR53C8XX_MAX_TAGS=32
CONFIG_SCSI_NCR53C8XX_SYNC=20
CONFIG_SCSI_NCR53C8XX_PROFILE=y
# CONFIG_SCSI_NCR53C8XX_IOMAPPED is not set
# CONFIG_SCSI_NCR53C8XX_PQS_PDS is not set

so at least the "_IOMAPPED is not set" parts agree. As you can see,
I'm using the sym53c8xx driver, but from reading the changelogs, the
sym53c8xx_2 driver should have all the capabilities of the sym53c8xx
driver, unless SuSE has done something peculiar with it.

FWIW, boot logs and dmesg outputs for a typical 9.2 attempt are at:
ftp://ftp.eskimo.com/u/j/jimo/SuSE-9.2/2.6.8-24-logs

and for comparison, the same info for my current 2.4.23 system:
ftp://ftp.eskimo.com/u/j/jimo/SuSE-9.2/2.4.23-logs

I'm booting from the 3-diskette set, and inserting modules diskette 5
for the sym53c8xx driver. The floppy0 errors don't appear until the
modules disk, and occur with two different disks, neither of which shows
errors during formatting. The diskette images were copied from CD with dd.

I have not tried using insmod, or using any of the control commands
via
echo "<verb> <param>" >/proc/scsi/sym53c8xx/0
as the parity control seemed to be a boot-only option. I should play
with those methods, I suppose, for lack of any other ideas.

I'll be happy to provide any additional info you think might be interesting.

Thanks for any help you can provide.

Jim

< Previous Next >
Follow Ups