Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: 9.2 scsi install: sym53c8xx: Unknown parameter `mpar'
  • From: Jim Osborn <jimo@xxxxxxxxxx>
  • Date: Sat, 19 Feb 2005 13:21:24 -0800
  • Message-id: <20050219212124.GF3359@xxxxxxxxxx>
On Sat, Feb 19, 2005 at 6:26:27AM -0500, Felix Miata wrote:
> I seriously doubt there's any liklihood that flashing will solve
> any of your problems... All my earlier SuSE installs to SCSI were
> with 2.4 kernels.

Thanks for the response, Felix. Since my HBA and my two SCSI HDs
work well with the 2.4.23 kernel and its sym53c8xx-1.7.3c driver,
I think if I'm to get this machine working with SuSE 9.2, it won't
need a new HBA BIOS.

The question at this point is: can I figure out what it takes to make
9.2 install in less time than I can learn what it takes to upgrade a
2.4-based system to the latest C compiler, libraries, applications,
etc., many of which I fear are going to be expecting a 2.6 kernel?
And being on a dialup connection, I'd prefer not to spend weeks
downloading all that stuff; I'd really prefer to have it all on a
set of CDs compiled against the right libraries. Like SuSE 9.2.

The reason I continue to beat my head against this installation is
that it seems tantalizingly close. I keep thinking maybe if I can
redirect one interrupt somewhere, or one dma channel, or figure out
the parameter to give to the HBA, that'll make it all work.

For example, what's with the flood of floppy0 errors when loading the
modules from the diskette? Is the image on the CD bad? Does it
require some special block size to dd? Is there some parameter I
should be giving at initial boot time to deal with that? There are
no complaints while loading the boot diskettes, just the modules,
from both the modules2 and modules5 images.

And what's with the "Unknown parameter" errors to the SCSI module?
The fact that they occur before the announcement of the HBA make and
model makes me think they're part of SuSE's linuxrc, not as a result
of contact with the HBA itself. Do I need to give the parameters in
French? If I could make any of the adjustments alluded to in the
2.6.8 docs on the SuSE CD, it seems I should be able to get this
thing to work. Are the floppy0 errors corrupting the sym53c8xx_2
module just enough to make it refuse parameters and generate parity
errors on one, and only one, of the HDs?

This is my one-and-only machine, so I don't have the luxury of
doing much hardware swapping, and since the HBA works so well
currently, I hate to just order another brand on spec. Your
experience makes me worry that even if I got a new motherboard
and controller, I might be facing equally difficult issues.

I think I'll put some effort into contacting the driver author,
Gerard Roudier, in hopes of his telling me whether persuing
his driver with the 2.6.8 kernel is a waste of time.

The one other respondent in this thread besides Carl said they had
been able to get 9.2 to install on a 53C1010 HBA, so apparently
there's at least one Lsi HBA working. Maybe they'll report if
they gave the module any parameters, and if so, what format they
were given in...

Cheers, and thanks again for the response,

Jim

< Previous Next >