Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Segmantation Faults
  • From: BandiPat <penguin0601@xxxxxxxxxxxxx>
  • Date: Mon, 21 Feb 2005 12:13:30 -0500
  • Message-id: <200502211213.30923.penguin0601@xxxxxxxxxxxxx>
On Monday 21 February 2005 09:54 am, Paul Trevethan wrote:
> Hi,
> running SuSEv9.2 with XFce4 4.2 here
>
> Could someone please explain to me how I go about tracking down the
> cause of Segmentation Faults that have started appearing in my web
> browsers?
>
> I usually use MozillaFirefox v1.0. I updated the video player "vlc"
> and all associated dependencies fro the Packman site using Synaptic.
> Everything went without error. Part of this update was the
> installation of the vlc mozillaplugin which I did not have before. I
> soft linked the plugin file to /usr/lib/browser-plugins as usual for
> mozilla updates.
>
> Now, I get nothing but Segmentation Fault when I try to run Firefox,
> Mozilla itself or Opera?! Konqueror is the only browser still kicking
> (and I do not like it).
>
> I will remove the plugin and its links to see if that is what caused
> this - I presume it is as it is the only web-related change I have
> made and they all worked yesterday?
>
> More generally though, especially if removing the plugin does not fix
> it, how does one go about tracking down the cause of a Segmentation
> Fault?
>
> Paul.
=========

Many times starting the program from the shell will give you quite a
verbose listing of what is happening. Also, you seem to understand
that removing the last things installed/setup, even your symlink, will
put you back to the point that things worked correctly.

regards,
Lee

--
--- KMail v1.7.2 --- SuSE Linux Pro v9.2 ---
Registered Linux User #225206
Sign at college bookstore:
Accepted at more colleges than you were--VISA

< Previous Next >
This Thread
References