Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] SCSI bus reset?
  • From: John Scott <praiserock@xxxxxxxxx>
  • Date: Mon, 21 Feb 2005 21:57:07 -0500
  • Message-id: <33cb9792050221185740890925@xxxxxxxxxxxxxx>
On Sat, 19 Feb 2005 19:41:03 -0800, Alex Daniloff <alex@xxxxxxxxxxxx> wrote:
> I'm using SuSE9.2
> The SCSI controller is
> RAID bus controller: Adaptec (formerly DPT) SmartRAID V Controller (rev 01)
> Vendor: Adaptec Model: 2000S FW:380E
> ADAPTEC RAID-5 Rev: 380EDPTM

Are you using the aacraid module for this card? I've got a 2200S and
I've got similar issues with 9.1. I've tried booting from the 9.2
disks and get the scsi resets and then a kernel panic. I even tried
the beta for RHEL 4 and got the scsi reset and then a kernel panic.

Went to Adaptec's site. Adaptec states that the latest firmware and
drivers from their site work, but I haven't had any success. After
going round and round with their support guys, they tried to say they
didn't support 2.6 kernels until I sent them the url on their site
that stated otherwise. Then they said they only supported the kernel
that shipped on the disks - no kernel updates supported.

I suspect that the aacraid module is having issues with the 2.6
kernels. I've googled it and have come across quite a few posts with
people having problems with Adaptec RAID cards and various distros.

The only combo I found that was stable using my 2200S was to use a 2.4
kernel distro with aacraid module. All the problems went away, but
how long can you stay on 2.4 kernels and get vendor support? At some
point, you move or you're on your own. My boss doesn't like that
option.

I've decided that I'm going to replace the Adaptec card with an LSI
Logic MegaRAID card. I haven't had any problems with any of their
cards yet (knock on wood). Guess I've got an expensive paper weight
for my desk now.

John

< Previous Next >