Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Firefox X display problem--Start Again
  • From: Chris Carlen <crobc@xxxxxxxxxxxxx>
  • Date: Mon, 21 Feb 2005 19:08:27 -0800
  • Message-id: <421AA22B.4050106@xxxxxxxxxxxxx>
Anders Johansson wrote:
On Monday 21 February 2005 02:29, Chris Carlen wrote:

anok@ting:~> Xlib: connection to ":0.0" refused by server
Xlib: XDM authorization key matches an existing client!
(firefox-bin:5671): Gtk-WARNING **: cannot open display:


"XDM authorization key matches an existing client" doesn't mean "you are not authorized". This is an old problem and it has nothing to do with running as root, so sux or kdesu won't help

Here's what you need to do: first turn off x authentication completely with "xhost +" (run as your regular user). Then run firefox once and let it start up, then close it down and re-enable x authentication with "xhost -" (again, run as your regular user). After that, things should work again as normal

Thanks for the input.

Unfortunately, it doesn't work.

Here is what I tried this time:

As root, deleted the entire contents of the /opt/firefox install dir.
As user, deleted the ~/.mozilla/firefox dir; then log out of X
As root, deleted the entire contents of /tmp
As root, reinstalled Firefox anew. It ran fine, and loaded the application automatically after installing. Closed it and then...
As user, ran command:

> xhost +

As user, ran firefox

Same results. Repeating infinite loop of error messages as shown in my OP, taking about 5 minutes to reach segfault.

Then I suspected maybe something was going bonkers related to my wife's international settings in her KDE setup. I logged into my account which has KDE in its virgin state since I don't normally use her 'puter. Same results.

The plot thickens:

I ran firefox as root. It worked, in the user's X session. Then I tried to run firefox as user with the root instance of Fx still running. The user's Fx then worked! Closing the root Fx, and trying to start Fx again as user fails.

Now things get wierder still. When I type a URL in either root's or the user's Fx window, the URL appears in the history list of BOTH windows. Thus, URLs entered as root appear in the history of the user's window and vice versa.

This is completely bonkers. I have never seen such silliness before.


Any ideas what is going on?


Thanks.




--
_____________________
Christopher R. Carlen
crobc@xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
SuSE 9.1 Linux 2.6.5

< Previous Next >
Follow Ups