Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Firefox X display problem--Start Again
  • From: Chris Carlen <crobc@xxxxxxxxxxxxx>
  • Date: Tue, 22 Feb 2005 06:42:42 -0800
  • Message-id: <421B44E2.40505@xxxxxxxxxxxxx>
Catimimi wrote:
Chris Carlen a écrit :
Thanks for the input.

Unfortunately, it doesn't work.

Here is what I tried this time:

As root, deleted the entire contents of the /opt/firefox install dir.
As user, deleted the ~/.mozilla/firefox dir; then log out of X
As root, deleted the entire contents of /tmp
As root, reinstalled Firefox anew. It ran fine, and loaded the application automatically after installing. Closed it and then...
As user, ran command:

> xhost +

As user, ran firefox

Same results. Repeating infinite loop of error messages as shown in my OP, taking about 5 minutes to reach segfault.

Then I suspected maybe something was going bonkers related to my wife's international settings in her KDE setup. I logged into my account which has KDE in its virgin state since I don't normally use her 'puter. Same results.

The plot thickens:

I ran firefox as root. It worked, in the user's X session. Then I tried to run firefox as user with the root instance of Fx still running. The user's Fx then worked! Closing the root Fx, and trying to start Fx again as user fails.

Now things get wierder still. When I type a URL in either root's or the user's Fx window, the URL appears in the history list of BOTH windows. Thus, URLs entered as root appear in the history of the user's window and vice versa.

This is completely bonkers. I have never seen such silliness before.


Any ideas what is going on?


Thanks.

Hello,

I didn't want to interfere earlier in your discussion, but as you seem to be lost, I can try to help you with firefox and thunderbird which are now working
very well in my box with SuSE 9.2 pro.
If you look in this list about 2 or three weeks ago, you'll have the history of my difficulties.

I tried to install the rpms for SuSE 9.2 and I got the same difficulties than you ! :-(
So I came back to firefox and thunderbird installers, during the installation process, you can read that "you have to install in a folder where you have writing permissions" !! It is not the case for the folder /opt/firefox or /opt/thunderbird !! =-O so I installed in my home folder and i no longer got error messages !! :-)

BUT, while starting thunderbird, the windows stops to open and as you I got segmentation faults !! :-!

I was desperated when I tried once more, and to go faster, decided not to import from previous applications AND :-) everything ran fine except that I'd to
manually configure the application. 8-)


Hello Michel. Thanks for your reply.

It seems you may have the clue that solves this mystery: "you have to install in a folder
> where you have writing permissions"

Now usually, we expect that a Linux application is designed to be installed as root so that all users can run the application independently. That is, the application's files are locked away in an installation directory where users do not have write access, so that they are not able to corrupt the application for other users.

Furthermore, if the application needs to store user-specific information, it will do so in a special directory in the users home. This is for instance, exactly the way Mozilla operates. So it was reasonable to expect that Firefox would be the same.

Indeed, Fx creates a dir under ~/.mozilla/firefox to store its user-related stuff.

So at this point I am still confused why the Firefox app would require that the *user* have write permissions to the install dir. Perhaps it is designed only to be installed in a user directory, not a system-wide dir. This is very unusual, but could explain the behavior I witnessed, where the history from two different users was coupled together.

But I don't think this is an acceptable design for a Linux application.

Nonetheless, I am curious to experiment with this app some more, so I will try two independent installs in two different user dirs. Then I will try running Fx as both users at the same time. If the two are still coupled together, then I am going to have a lot of words for the bug report I make to the Fx developers.


Thanks again for your response.

Good day!










--
_____________________
Christopher R. Carlen
crobc@xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
SuSE 9.1 Linux 2.6.5

< Previous Next >