Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Segmentation Faults - Solved
  • From: Paul Trevethan <plist@xxxxxxxxxxxxxxxx>
  • Date: Wed, 23 Feb 2005 02:16:49 +1100
  • Message-id: <20050223021649.51efb189@xxxxxxxxxxxxxxxxxxxxxx>
I posted recently about segmentation faults at startup that had occurred
in Firefox, Mozilla & Opera, making them impossible to run. These
started after having tried installation of an update to the Vlc plugin.
All browsers were working perfectly fine before this.

FWIW, as an archive reference for others who perhaps face a similar
problem, I just thought I would post my solution, explaining the logic
process I followed.

I don't know how but it would appear that the xineplugin.so became
corrupt (or in some conflict) when I installed the vlc plugin rpm. I
suspect corrupt (perhaps overridden?) because removing the vlcplugin rpm
did not fix the problem.

I found the solution by a simple process of logical elimination. I
always place original plugin files in /usr/lib/browser-plugins. I then
replicate that directory through symlinks in
/opt/MozillaFirefox/lib/plugins.

I made a backup copy of my bookmarks file and moved it to safety. I then
uninstalled Firefox in its entirety, being careful to remove $HOME-based
directories etc. I then used apt-get to re-install Firefox. It ran just
fine, so, problem was definitely in old (plugin) config. The
re-installation gave me a 'default' set of plugins. I compared the two
directories above and, one by one, added symlinks for the plugins still
in /u/l/b and not in the new /o/M/l/p - running firefox from a terminal
window (to see errors) after each one.

It fell over when I added the symlink for the xineplugin.so. Removed the
link again, worked fine. Solution found!!

Mind you, it could have been one starting with 'a' not 'x'?! Mplayer
and Kaffeine plugins work so I have just left the rogue out.

Hope the logic outline helps someone?

This does raise a question in my mind about the use of
/usr/lib/browser-plugins though. Firefox obviously does not look there,
in my case anyway, so what does. I thought it was a new 'central
repository' that all SuSE browsers under SuSE would use. Is that only if
you install from SuSE dvd perhaps?

Paul.

< Previous Next >
Follow Ups