Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Konqueror Audio CD Browser Not Working
  • From: wmeler <wmeler@xxxxxxxxxxxxx>
  • Date: Sat, 29 May 2004 15:31:21 -0400 (GMT-04:00)
  • Message-id: <23558368.1085859081685.JavaMail.root@xxxxxxxxxxxxxxxxxxxxxxxxxx>
I have a few problems. Getting #1 below to work would be my top priority, because I want to be able to rip my CDs into MP3 format very easily. (I could not get abcde to work, and I would much prefer to use konqueror directly.)

1) I am using KDE 3.2.2. I cannot get Audio CD Browser working. I installed the latest kdeaddons3-sound.rpm, kdemultimedia3-extra.rpm, kdemultimedia3-sound.rpm, and kdemultimedia3-video.rpm files today from the SuSE download site if this matters.

2) Regarding my CD-ROM, k3b v0.11 can copy a data CD just fine, but cannot copy an audio CD. It complains about not being able to open /dev/sr0 (but reads just fine from sr0 when worrying about a data file). I cannot mound an audio CD, but can mount a data CD.

I managed to read an audio CD successfully using xcdroast, but would prefer to use k3b for everything if I can get it working.

If I do an "eject sr0" it ejects a CD-ROM just fine.

3) I also have a CD-RW that can do things like burn mp3s from k3b. However, it cannot mount even a simple audio CD from KDE. I think maybe my setup has been a bit mangled by k3b_setup.
As root, f I do an "eject /dev/hdc" it says "eject: unable to eject, last error: Invalid argument"


Here is a partial listing of my /dev directory:

>>>ls /dev/cd* -al
brw-rw---- 1 root disk 19, 128 Sep 9 2002 /dev/cdouble0
brw-rw---- 1 root disk 19, 129 Sep 9 2002 /dev/cdouble1
lrwxrwxrwx 1 root root 3 May 18 03:22 /dev/cdrecorder -> sr0
lrwxrwxrwx 1 root root 3 May 18 03:22 /dev/cdrom -> hdc
brw-r----- 1 root disk 24, 0 Sep 9 2002 /dev/cdu535

>>>ls -al /dev/hdc
brw------- 1 wmeler disk 22, 0 Sep 9 2002 /dev/hdc

Here is my /etc/fstab file:

>>>cat /etc/fstab
/dev/hda2 / reiserfs defaults 1 1
/dev/hdb1 /data1 auto noauto,user 0 0
/dev/sda1 /dos/C vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
/dev/sdb1 /windows/D vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
/dev/hda1 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs noauto 0 0
/dev/cdrecorder /media/cdrecorder auto ro,noauto,user,exec 0 0
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
/dev/sda1 /media/sda1 auto noauto,user,exec 0 0 #HOTPLUG B3Fu.mrp5DZ2Q9VE
/dev/sdb1 /media/sdb1 auto noauto,user,exec 0 0 #HOTPLUG B3Fu.UBr3z+wAy2B


Cheers,
wmeler

< Previous Next >
This Thread
  • No further messages