Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Wireless, DHCP, Firewall Issues [SOLVED, sort of ...}
  • From: "Jim Poteet" <JPOTEET@xxxxxxxxxxx>
  • Date: Wed, 26 May 2004 23:32:21 -0500
  • Message-id: <s0b52910.055@xxxxxxxxxxxxxxxx>
> >>> "Scot L. Harris" <webid@xxxxxxxxxx> 5/26/04 10:18:15 PM >>>

>>On Wed, 2004-05-26 at 22:07, Jim Poteet wrote:
>> My setup is DSL, an Alcatel modem, a Netscreen vpn appliance (that is functioning as the DHCP server) and a Linksys wireless access point.
>>Several PCs (a mixture of W98, >>WXP, and SuSE 9.0) are wired into the LAN. All are functioning normally as far as DHCP ip assignments,
>>DSN lookups, pinging and browsing the internet.
>>
>> I have a Dell Latitude LS laptop with a Linksys wireless card and an ethernet connection into the LAN.
>>
>> When the wireless card is stopped (ifdown wlan0) and the ethernet is cabled in, everything works fine.
>>
>> When I unplug the ethernet cable, I can ping and access all of my local devices using the wireless device. However, I cannot get out onto the internet with pings or browses.
>>

>Based on your description above I would suspect you don't have the
>correct default gateway setup. In both cases run a netstat -rn and see
>what the default gateway is set to.

Scot ...

Thanks for your help.

The gateway was set correctly for both NICs. However, I noticed when running the netstat that both interfaces were reporting, even with the ethernet cable pulled and even after an ifdown command. I tried cycling through YaST, with the cable pulled, before ifstatus and netstat recognized that the interface was not there. After this, everything seems to be working. I'm still trying to figure out exactly what transpired and why this would let the local stuff work, but not the remote.

I'm going to mark this one as closed for now, since things are working, but I will go through the steps in an orderly fashion to see if I can understand it.

Thanks again.

.... Jim


>> If I manually assign an ip, everything works fine.
>>
>> YaST setups for the two devices look okay. (DNS and gateway information is shared.)
>>
>> There's nothing in the Netscreen setup or the wireless AP setup that would block an ip address (the ip address that won't go out over the wireless connection works just fine when manually assigned.
>>
>> I chatted with a Linksys tech to no avail. The access point is just a switch and doesn't tinker with ip addresses.
>>
>> Any suggestions on where to look?

>It is not clear to me in your description but when you manually setup
>the IP addressing do you use the same address as that assigned by the
>DHCP server? Or is it a different address? Is it just names
>(yahoo.com) or IP addresses that you can not get to on the Internet? If
>you can ping yahoo.com's IP address then the problem is a DNS issue. If
>you can't ping the IP address then it is most likely a gateway issue.

Neither URLs nor IPs would go. Internally, I could only test pinging IPs, since I didn't have a DNS function running anywhere inside.

>You indicate the netscreen is acting as your DHCP server. Check your
>wireless AP and make sure you have disabled its DHCP server. What could
>be happening is you may be assigning the same IP address as another node
>on your lan if the linksys is serving address as well as your netscreen
>and they are in the same range. Duplicate IP addresses can cause some
>very strange results at times.

The AP DHCP is turned off.

>But my 2 cents is on the gateway not being correct. That is the
>simplest thing that would explain why you can ping local devices but not
>get out on the Internet.

>If that is the case then a netstat -rn should show it up. This could
>still be caused by the linksys serving out DHCP addresses when it is not
>fully configured with gateway info and such.


>--
>Scot L. Harris <webid@xxxxxxxxxx>


>--
>Check the headers for your unsubscription address
>For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
>Also check the archives at http://lists.suse.com
>Please read the FAQs: suse-linux-e-faq@xxxxxxxx




< Previous Next >
Follow Ups