Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] 9.1 and lack of Gnome
  • From: Marcus Brubaker <marcus@xxxxxxxxxxxxx>
  • Date: Wed, 26 May 2004 16:56:14 -0400
  • Message-id: <1085604974.16695.52.camel@xxxxxxxxxxxxxxxxxxx>
On Wed, 2004-05-26 at 16:44, Brooks wrote:
> Tried installing XD2 and it won't go. Here's what I get:
>
> brooks@84:~> xhost +localhost
> localhost being added to access control list
> brooks@84:~> su
> Password:
> 84:/home/brooks # wget -q -O - http://go.ximian.com |sh
> ==> Autodetecting system type...
> ==> Checking $DISPLAY and X permissions...
>
> The Ximian Desktop Installer is a graphical application, and
> either you have no DISPLAY variable set or the root user does not
> have permission to access your X server. Run 'xhost +localhost'
> before becoming root, and make sure that the DISPLAY variable is
> set correctly before running the go-ximian script.
>
> Cleaning up temporary files... done.
>
>
> As you can see, I get this message AFTER I run the 'xhost +localhost' command
> that it suggests. I have no idea how to check whether I have a DISPLAY
> variable set.

xhost +localhost will allow you to connect to the X server, but DISPLAY
may still be unset. Try:

xhost +localhost
su - root
export DISPLAY=:0.0
wget -q -O - http://go.ximian.com | sh

Regards,
Marcus


< Previous Next >
Follow Ups