Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Installing fonts in 9.1 breaks gimp & causes font problems in gnome apps
  • From: "Mark A. Taff" <marktaff@xxxxxxxxxxx>
  • Date: Tue, 25 May 2004 19:44:57 -0700
  • Message-id: <200405251944.57236.marktaff@xxxxxxxxxxx>
Hi all! Hope someone can help me.

I'm having problems with fonts on 9.1 Pro. The problems occur on all 3
machines I have running 9.1. It worked fine under 9.0 w/kde3.2, so it must
be something new.

Basically, installing extra true type fonts causes the following errors:

Gimp-2.0 starts to run, then crashes. Running from a console gives error:
Gimp-Text-ERROR **: file gimpfontlist.c: line 235
(gimp_font_list_font_desc_from_pattern): assertion failed: (res ==
FcResultMatch)

Running it with the -f flag, it starts and runs fine (bypassing the error).
However, then the fonts look just like in other gnome apps.

GKrellm uses nice fonts for the krells, but the config dialogs have the ugly
fonts. e2k-gui is also affected.

Generally, certain characters seem bolded, like all caps and lc chars 'vywax'

I've tried everything I can think of to fix it. The only thing that works is
deleting the newly installed fonts, then running `fonts-config -f`

I am installing 522 more true-type fonts (38.6MB) for a total of ~980
true-type fonts.

I've tried installing them with the KDE font-installer, and from Konqi, and
from the cli. I've tried installing them in my "personal" folder, as well as
globally.

I've tried all the normal solutions, like xset fp rehash for the X core fonts,
to fonts-config -f for xft.

I've also made sure that the new fonts have the same user/group and file
permissions as the existing true-type fonts.

After a couple of days working on this, I'm fresh out of ideas. Any help
would be greatly appreciated.

Regards,
Mark

< Previous Next >
Follow Ups