Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Re: USB scanners in 9.1
  • From: Fergus Wilde <fwilde@xxxxxxxxxxxxxxx>
  • Date: Thu, 20 May 2004 15:39:14 +0100
  • Message-id: <200405201539.14708.fwilde@xxxxxxxxxxxxxxx>
On Thursday 20 May 2004 15:05, Graham Smith wrote:
> On Thu, 20 May 2004 23:06, Fergus Wilde wrote:
> > > Does Yast recognise your scanner model?
> >
> > Yes, it does. It apparently sets up fine, and even tests OK, but when you
> > try to access it via xsane:
> >
> > Failed to start scanner. Error during device I/O.
> >
> > But Sid's vuescan and SuSE 8.2 and 9.0 don't find anything wrong with the
> > i/o.
> >
> > I've used the newly updated YaST scanner setup module, still no go.
> >
> > > If not, I suggest you start looking at the hotplug usb tables to make
> > > sure your scanner has an entry. /etc/hotplug/usb/sane-hardcoded.usermap
> >
> > Well - what's it supposed to look like? Mine reads:
> >
> > more /etc/hotplug/usb/sane-hardcoded.usermap
> > desktopdev 0x0003 0x03f0 0x0101 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00
> > 0x00 0x0

Hi Graham, thanks again for taking time over this on my behalf

> I think there was an update to Yast for the scanners in the last 24 hrs,
> have you checked with YOU for the latest updates?

Yes, as I said above , I did use the newly updated YaST scanner setup module,
still no go - same for the network card, but that's another story ...
>
> I just did a little bit of investigation. Your scanner Epson 610 is in the
> sane-hardcoded.usermap file.

> Vendor 0x04B8 Model 0x0103 as per the details found here
> http://www.qbik.ch/usb/devices/showdev.php?id=1120
>
> So it should work. Check with YAST--> Hardware --> hardware to see if it is
> being detected in the USB devices.

Mine's a an Epson Perfection 2450, but it certainly should work, as you say -
indeed if I reboot into SuSE 8.2, as I'm going to have to in a few minutes to
get my work done, it'll work fine now!

Yes, it is seen correctly. It all reads out fine in YaST, as I've said, model
identified correctly, etc. Just that YaST doesn't seem to be capable of
making sane see the thing, or see it in a usable way at least.

The hardware info says:

HWClass=scanner
Model=Epson Perfection 2450
Configured=yes
Available=yes
Needed=no
Active=unknown
Bus=0x86
BaseClass=0x10c
VendorID=u04b8
DeviceID=0112
DeviceName=Perfection 2450
VendorName=Epson
RevisionName=1.01
SysfsID=/devices/pci0000:00/0000:00:1d.7/usb1/1-5/1-5:1.0
SysfsBusID=1-5:1.0
Hotplug=4
HWClassList=00010008000000
Res.Baud=1500000,0,0,0x00,0x00
UniqueID=BUZT.KMmX0iPD370

I'm saying correct, I mean it gets the name right - the other numbers could be
junk, I wouldn't be able to guess ...

>
> The main Sane page for Epson is here
> http://www.freecolormanagement.com/sane/index.html
>
> You can get the Epson backend drivers from
> http://www.epkowa.co.jp/english/linux_e/index.html
> I have never tried/used these drivers as I always found that the Sane ones
> work.

Thanks a lot Graham, much appreciated. I may have a go at fixing this again,
but I'll need to find some time. At the minute 9.1 is too flaky to fight
with any more. New versions need to offer more, not less than old versions
and this ain't happening at my end.
>
> --
> Regards,
>
> Graham Smith
> ---------------------------------------------------------

--
Fergus Wilde
Chetham's Library
Long Millgate
Manchester
M3 1SB

Tel: +44 161 834 7961
Fax: +44 161 839 5797

http://www.chethams.org.uk

< Previous Next >