Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] ReiserFS problem? - (probably) solved for me
  • From: "Ejnar Z. Rath" <ezr@xxxxxxxxxxxxx>
  • Date: Wed, 19 May 2004 15:03:48 +0200
  • Message-id: <OF4FB0096A.A1A7C70D-ONC1256E99.0046BF1A-C1256E99.0047C26D@xxxxxxxxxxxxx>





"Ejnar Z. Rath" <ezr@xxxxxxxxxxxxx> wrote on 29-04-2004 12:56:03:
> Brad Bendily <brad@xxxxxxxx> wrote on 28-04-2004 17:30:41:
> > I have recently setup Suse 9.0 on a machine and configured
> > it to be used as a Kiosk station.
> > I used ReiserFS as the file systems on my 3 partitions I
> > created. Since I've the machine up we have had two power outages.
> > The problem is that when the machine starts up again the
> > file systems don't get mounted and I get brought to the
> > root login prompt and get asked to login and run
> > fsck (or reiserfsck). And it trys to replay journals and
> > do all that stuff. The first time it happened I recovered
> > and it all worked. Today when it happened it wiped out my
> > /home partition and everything was lost. Mostly.
> >
> > I have my work desktop setup with ext3 partitions and the
> > same power outage didn't affect this box.
> >
> > I thought ReiserFS should be able to handle the instant
> > reboots. Should I convert the kiosk PC to ext3? Or am I
> > missing something in my ReiserFS setup?
> I'm having very similar problems resulting in my filesystems
> containing /var and /home being corrupted several times - very
> disappointing.
>
> Making an "reiserfsck --rebuild-tree" gives me
> most of the file systems back but I always end up with a
> bunch of files in lost+found and some really lost files.
>
> I'm using SuSE 9.0, kernel 2.4.21-202-default. The file systems
> are created on volumes of lvm-1.0.7-105, and the file systems
> use reiserfs-3.6.9-33. On an IBM T40 ThinkPad which of course
> shouldn't matter.
>
> Any hint would be highly appreciated.
Thanks to everybody for your input. Maybe I should have mentioned that the problems I experienced
were not related to unstable power supply but to hangs related to various testing on my laptop.

Anyway - after upgrading to SuSE 9.1 with kernel 2.6.4-54.5-default I have not lost anything at the
couple of times I have had to reboot by removing the battery. At boot a lot of transactions are
reported replayed in the file systems and everything is fine. With 9.0 I almost always lost
something in similar situations and no replay of transactions was reported at boot after a crash.

Regards,
--
Ejnar


< Previous Next >
This Thread
  • No further messages