Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Problem - Turckmmcache, Apache2 and SuSE 9.1
  • From: poeml@xxxxxxxxxxx
  • Date: Wed, 19 May 2004 14:25:24 +0200
  • Message-id: <20040519122524.GA10560@xxxxxxxxxxx>
On Wed, May 19, 2004 at 02:05:25PM +0300, Andrei Verovski wrote:
> Hi, Peter,
>
> Thanks a lot for reply.
>
> Yes, of course, I have php4_session installed. In fact, I have
> installed php4_core, which do include a lot of extra modules. Please
> note that I have recompiled turck mmcache with the current install of
> PHP4.

Sorry, I don't think I can help much further. Can you check the order in
which php4 loads its modules?

Oh, do you load the php4 module into apache _before_ loading any modules
that depend on it?

> On May 19, 2004, at 11:50, poeml@xxxxxxxxxxx wrote:
>
> >On Tue, May 18, 2004 at 10:34:38PM +0300, Andrei Verovski (aka
> >MacGuru) wrote:
> >>I have compiled and installed (precisely following instruction)
> >>turck-mmcache
> >>2.4.6 for Apache2-2.0.49-23/php4-4.3.4-43.3 on SuSE 9.1.
> >>
> >>Unfortunately, I cannot start Apapche2 anymore, I am getting this
> >>error
> >>message:
> >>
> >>/usr/sbin/httpd2-prefork: error while loading shared
> >>libraries: /usr/lib/php/extensions/mmcache.so: undefined symbol:
> >>php_session_register_module
> >
> >Do you have all needed php4 modules installed, e.g. the package
> >php4-session?
< Previous Next >
Follow Ups