Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: Help! Samba Client w/ SuSE 9.1
  • From: "Art Fore" <afore@xxxxxxxxx>
  • Date: Tue, 18 May 2004 17:51:15 -0700
  • Message-id: <40AAAF83.2010102@xxxxxxxxx>
I got the problem with WinXP solved by renaming the machine in Linux. However, am still not able to loging to a win2k server. Using smbclient at the command line, I get NT_STATUS_LOGON_FAILURE. We checked the log on the domain server, it says cfould not find file for sha-linux$ but the machine name is sha-linux, so it appears the computer name is getting a $ added to it during logon. Any idea what file this is contained in in linux? I looked, but could not find anything.

Also have a few more questions if anyone has an answer.

I guess smb and nmb services are for samba server, but do I need samba server just to access a win2k network if I am not sharing any files?

At one time, I could brouse the windows network, domain, and see the computers on the network with konqueror. If I tried to login to one of the servers I am authorized to, I would get smb://datacfenter protocol died unexpectedly (datacenter is the name of the win2k server) This is probably because of the NT_STATUS_LOGON_FAILURE seen in the command line. Now, I just click on the windows network in the network browser, it comes up with there is a bug and to report it to KDE. I had started smb and nmb through the runlevel editor before without configuring saamba server. Now that I configured samba server as a file-print server, I can no longer do that. Any suggestions why would be welcome.

Can you have samber server and samba client running at the same time? I would assume so, but am not sure? If they are running at same time, can then have the same computer name?

There is a check box in samba server for "Also use smb info for Linux Authorization" I guess uses smbpasswd file to authenticate logging into Linux, it that correct? Is this required for logging into a win2k share? In other words, which way is it best to have this box, checked or unchecked?

Art



Art Fore wrote:

I never did get samba clinet working with 9.0, now, 9.1 is have some of the same problems, but am a little closer. Been through all of the emails on the llist about samba, but could have missed something.

I setup the samba client with Yast which found the domain (win2k network at work) with no problem, I put in my win login name and win password. Everything seemed to be OK. When I go to Network Browse, it finds the windows network and the domain, but when I try to open one of the server folders that I know I have acces to, I get a dialog box for login, put in my win login and password, it comes up with nt login failure.

I have added the password with the smbpasswd -a, and I have added my linux login name versus win login name in the smbusers file. Still no luck after restarting.

I use smbclient -L on the server with -U login name, it asks for password, I put in the password, it comes back fine. If I change the login by 1 letter, I then of course get an nt login failure.

Worst thing is when I boot back into XP, I cannot login to the domain. I have to change to a workgroupo, reboot, change back to the domain, reboot, before I can login again. If I go back into suse, bhen back to XP again, have to do it all over again.

It appears to me that samba client is trying to login to the domain with my linux user name, even though I entered the win username when I logged in the first time. (it no loger asks for it)

Anyone have any suggestions furtther or knows where the yast samba client app puts the info when you first set it up?

Art



< Previous Next >
References