Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Bootsplash problems...
  • From: Vince Littler <suse@xxxxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Mon, 17 May 2004 17:37:15 +0100
  • Message-id: <200405171737.15758@xxxxxxxxxxxxxxxxxxxxxxxxxx>
On Monday 17 May 2004 2:54 pm, Martin Mielke wrote:
> Hi list,
>
> yes, you guessed it: I want to change the bootsplash stuff and I can't
> go any further...
>
> I did the following, as root:
>
> mkdir /etc/bootsplash/themes/THALES
> mkdir /etc/bootsplash/themes/THALES/config
> mkdir /etc/bootsplash/themes/THALES/images
>
> Then I put all the bootsplash-1024x768.jpg and silent-1024x768.jpg on
> the images/ directory.
> After that, I just created:
>
> ln -s /etc/bootsplash/themes/THALES /etc/bootsplash/themes/current
>
>
> and modified /etc/sysconfig/bootsplash as follows:
> ---
> ## Path: System/Boot
> ## Description: selects bootsplash graphics theme
> ## Type: string
> ## Default: SuSE
> # Choose the bootsplash theme. It should be based in
> # /etc/bootsplash/themes/
> THEME="current"
> ## Path: System/Boot
> ## Description: enables/disables bootup graphics
> ## Type: yesno
> ## Default: yes
> #
> # SPLASH can be set to "no" to turn off the splash-screen on console 1
> # at boot time (after kernel load).
> #
> # SPLASH=no to disable the splash screen
> #
> # SPLASH=yes to show the splash screen
> #
> SPLASH="yes"
> ---
>
> The file /etc/bootsplash/themes/THALES/config/bootsplash-1024x768.cfg
> contains the full path to both JPEG images:
> ---
> jpeg=/etc/bootsplash/themes/THALES/images/bootsplash-1024x768.jpg
> silentjpeg=/etc/bootsplash/themes/THALES/images/silent-1024x768.jpg
> ---
>
>
> Finally, I ran 'mkinitrd':
> ---
> Root device: /dev/hda2 (mounted on / as reiserfs)
> Module list: reiserfs
> Kernel version: 2.4.21-202-default (i386)
> Kernel image: /boot/vmlinuz-2.4.21-202-default
> Initrd image: /boot/initrd-2.4.21-202-default
> Shared libs: none
> Modules: kernel/fs/reiserfs/reiserfs.o
> Bootsplash: current (1024x768)
> ---
>
> So far, so good...
> When I reboot the machine, I get the same SuSE-background with the
> menu-box (Linux | Failsafe | Memory Test) and no matter what I choose
> (silent, verbose) now I end up with a black screen showing me how's the
> boot process going and a Tux on top of everything (just like when you
> choose 'verbose').
>
> Your ideas/comments/solutions on this are much appreciated.
>
>
> Thanks!
> Martin


Have you had a bootsplash working? or are you trying to do one from new?

What you have not given us is your GRUB or LILO boot line. Obviously, you must
have a vga=* value set, because you can see Tux, but you may need to set
vga=<something>, to give 1024*768 at the right resolution.

hth

Vince Littler


< Previous Next >
Follow Ups
References