Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] 9.1 Live CD won't boot working 8.1 pro system
  • From: John Grant <jmgrant@xxxxxxxxx>
  • Date: Sun, 16 May 2004 18:12:35 -0700
  • Message-id: <20040516181235.A19294@xxxxxxxxx>
Just a followup..

First, I got a chance to play a little more this afternoon & noticed
upon closer inspection that it's not actually the aic7xxx driver that is
causing the kernel panic. The actual stack dump shows aic79xx as the
guilty party. There is a "FATAL:...." message that comes out just
before the oops output and that -does- mention the aic7xxx driver that
was throwing me off. Just after that though it says "loading aic79xx",
and just after /that/ comes the oops.

I also tried booting in safe mode. This mostly doesn't work for me
either. It doesn't panic however, and it gets me to the desktop, which
is good, I guess.. better anyway. :)

When booting in safe mode I again get the message about a missing
aic7xxx.ko, followed by "loading aic79xx". Whereas before I got the
oops/panic however, now I get a couple promising messages about IRQs
detected, then a couple minutes of rapidly scrolling text with all sorts
of cryptic errors about SCSI-related stuff (to use the technical
phrase), followed by the rest of the boot sequence and ultimately the
desktop.

Yay. Sort of. Unfortunately I can't see my SCSI drive at this point.
An lsmod shows the aic79xx module loaded with a use count of 1, but an
"fdisk -l" shows the only SCSI disk available as being the portable
firewire drive I have attached to my soundblaster card (for backups).
Neither the old Seagate HD nor the CDR drive I have attached to the
built-in SCSI bus are accessible, or even visible.

At this point I can get access to the SCSI drive(s) if I do a "rmmod -f
aic79xx", followed by "insmod aic79xx". After that the drive appears in
an "fdisk -l" with the proper partition info. I didn't want to risk
actually mounting it at that point (it has the /home, /boot, and / dirs
for my working 8.1 setup), but I did a dd as a read test, which seemed
to work fine.

So I'm guessing that something else in the boot process is messing up
things for the aic79xx driver module. I noticed that the boot process
attempts to load drivers for "sym53c8xx" and "aic7xxx" before getting to
my "aic79xx". Can anyone tell me how to disable these from the boot
prompt so I can see if either of those are the problem?

Also, not being a big fan of writers cramp I didn't copy down the oops
text. I did take a couple barely-legible pics of the oops/panic message
and stack dump with my digital camera though. If anyone's interested
just let me know where to send them.

Finally, just to clarify, the live CD I'm using is one I burned from an
ISO I downloaded from the link off www.suse.com Friday evening. I don't
know if it makes a difference, but I thought I'd mention that just in
case it's not the same as the one included in the 9.1 retail box.


On Sun, May 16, 2004 at 10:00:02AM -0700, John Grant wrote:
> I have a working 8.1 pro system that I'm thinking about upgrading to
> 9.1. However, this morning when I tried to boot the system from the 9.1
> live CD I get an oops and kernel panic when the boot process tries to
> load the aic7xxx driver.
...

< Previous Next >
References