Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] 8.2 to 9.1, wireless no longer works
  • From: Richard Atcheson <ratcheson@xxxxxxxxxxxxx>
  • Date: Sat, 15 May 2004 01:03:57 -0500
  • Message-id: <200405150103.57767.ratcheson@xxxxxxxxxxxxx>
On Friday 14 May 2004 11:34 pm, Steve Jacobs wrote:
> I recompiled the ndiswrapper, but when I insmod the resulting ndiswrapper.o
> I get an error (unfortunately I don't recall what exactly, other than the
> word 'maagic' was in there somewhere).
>
> I think my best course of action would be to completely remove the exisitng
> ndiswrapper (installed sometime around last December - maybe version .2?)
> and apply the latest version of ndiswrapper to the new Suse. But I don't
> know how to do that.
>
> help?

Steve it's easy after you've done it 15 times!. I just went through a similar
experience with my Compaq and Dell laptops.using ndiswrapper which is at
version .7 now.

Remove the current driver with modprobe -r ndiswrapper, then:

Download the latest ndiswrapper, find your windows driver for your Inspiron,
in case you need it. I had earlier used the driver for the broadcom F5D7010
card which is the bcwml5.inf that came with that card, and it worked fine on
the Dell BCM internal wireless nic. You could get lucky too! Broadcom has
drivers you can download for your machine, as does Dell.

The sequence I went through is:

Make sure you have the source for your kernel installed in /usr/src then:

1. Untar the ndiswrapper. I use konqueror. After the tarbal is downloaded I
click on it in konqueror, konqi then opens another window with a folder
holding ndiswrapper. Drag that folder to the /usr/src dir and drop it. It
is untarred!
2. use your konqi to open and read the install file in that folder, It gives
the easy howto. Simply follow it.

3. Using your bash shell, su, then enter your root password and cd to
the /usr/src/ndiswrapper directory.
4. type make install
5 have some coffee.
6. When it finishes make sure there are no error messages at the end.

7. Read the INstall again to see what commands to enter.

8. You should know the path to the driver so you can do the driver install.
Mine went in with:
ndiswrapper -i /home/download/bcwml5.inf

Again, all this in in the Install file in the Ndiswrapper directory.

9. now do a ndiswrapper -l to see if the driver is there.

10. next I did a :
modprobe ndiswrapper

Then do iwconfig to see what you have.

you should see wlan0 with a bunch of settings for your nic. Then next steps
will let you set up the nic.

12. Type iwconfig and you will see the various settings you can use to setup
the nic. If your Access Poiint is secured then you need to set the encryption
to the proper word. That's done with:
iwconfig wlan0 enc nnnnnnnnnnnnn where nnnn = the 26 character hex key.
All this comes from Section 4 of the install file.

13. Set the Mode, I use Managed but you can use whatever you think is
necessary.

14. My setup departed from the Install instructions at this point, iwconfig
set the encrytion key using:
iwconfig wlan0 enc <your key goes here> and not the suggestion in the Install
file.

15. Now came the setting of the essid. This one can be a bit daunting. It is
supposed to be set with :
iwconfig wlan0 essid <your ssid here>

Check it by doing iwconfig
if ESSID is followed by a blank then you gotta play a bit.

Mine eventually got set after I did ifconfig wlan0 up followed by the above.

16. Finally I did:
dhcpcd wlan0
and it started working.

As the instructions say, if it all works then do ndiswrapper -m which should
modify your modules.conf file.

If it is all working you should be able to do
rcnetwork restart and see the NICs shut down and restarted with the wlan0
getting its IP from your router.

Without going into more boring detail, the proof of all this is if it fires up
when you reboot.

There's got to be someone out there that knows what the proper sequence is and
maybe they will tell us the secret. This series of fingermagic worked on
both my computers - Eventually!

Persistence, determination, and being methodical are the keys. Above all,
keep notes on what you did and the resulting response/error messages.
Otherwise no one will be able to tell where things are going wrong and how to
fix any problem.

One hickey comes to mind. On the Dell, I had to delete the YAST setup for the
internal WIRED NIC. Otherwise I could not set the essid for the wireless and
it would not get its IP on boot.

Good luck,
ra



< Previous Next >
References