Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] SUSE 9.1 & Firewire harddrive
  • From: "Art Fore" <afore@xxxxxxxxx>
  • Date: Fri, 14 May 2004 13:12:45 -0700
  • Message-id: <40A5283D.9020301@xxxxxxxxx>
Got another drive kit with USB2 & Firewire and tried the same disk drive in the USB2. Same thing as with firewire drive, it just comes up with different mount point in /media.. A work colleague has Mepis installed, and he tried it, it works great also as firewire. I downloaded the KDiskFree (kdf), which Mepis uses, and installed it. Now I can mount and access the ntfs partition, but when doing the reiserfs partition, it says it is already mounted. Guess I need to figure out how to stop it from the automatic mounting somehow.

Kernel is the default Suse kernel after yast online update.

Art

Jorge Manuel B. S. Vicetto wrote:

Art,

is this an exclusively Firewire drive or an USB 2.0 / Firewire drive? If it can
be used with USB 2.0 I can understand your preference for Firewire, but I would
suggest you try to make it work with USB. That way you could try to diagnose if
the problem is in fstab or if it's somehow related to firewire.
I've a USB 2.0 / Firewire drive, but I'll be honest and admit I've yet to play
with Firewire - hey USB works!!! ;-) I've used it SuSE 9.0, which doesn't
include support for USB 2.0 in the default 2.4 and 2.6 kernels - or so I think.
I'm currently using it with a Gentoo 2004.0 system running the 2.6.5 kernel. If
you're interested I might try to use the Firewire connection and let you know
my results.
Where are you getting the 2.6.4 kernels for SuSE 9.0? Are you using Kraxel
builds? I thought he had moved on to 9.1 and that we had to use the kernels of
the day by Mantel!


Quoting Art Fore <afore@xxxxxxxxx>:

Having problems with Firewire harddrive that worked in SUSE 9.0 Here is
info belo.

NOTE: was having problems of unmounting hda2 and firwire drives after
being accessed by Konqueror, would say drive was busy. Only way to
unmount was to kill konqueror instead of closing it. YOU upgraded kernel
to 2.6.4-54.5 fixed this plus an error during booting about PCI modules.

fstab entries
/dev/hda7 / reiserfs
acl,user_xattr 1 1
/dev/hda6 /data1 reiserfs
acl,user_xattr 0 0
/dev/hda2 /windows/C ntfs
ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda5 swap swap
pri=42 0 0
devpts /dev/pts devpts
mode=0620,gid=5 0 0
proc /proc proc
defaults 0 0
usbfs /proc/bus/usb usbfs
noauto 0 0
sysfs /sys sysfs
noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs
fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/sda2 /Firewire/winc ntfs
ro,noauto,users,uid=afore,gid=users,umask-0002 0 0
/dev/sda6 /Firewire/linux reiserfs
noauto,uid=afore,gid=users 0 0

After plugging in the firewire drive, I get the following entries added
to the mtab file.

/dev/sda6 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p6 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda3 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p3 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda5 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p5 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda1 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p1 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda2 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p2 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0

sda1 is the only folder I can open. All of the other folders come up
"cannot enter folder". Same as root. Strange thing to me is they all
show fs-floppyfss, however, sda1 is fat-32, sda2 is ntfs, sda6 is
reiserfs

I then mount /dev/sda2 /Firewire/winc and dev/sda6 /Firewire/linux, I
get the following added to the mtab file

/dev/sda2 /Firewire/winc ntfs rw 0 0
/dev/sda6 /Firewire/linux reiserfs rw 0 0

I notice the sda2 is rw in both the /media and /Fire/winc entries.

I can access /Firewire/linux (sda6) a user, no problem.

I can access /Firewire/winc (sda2) only as root and I cannot change
permissions to allow users to view the directory. Trying to change
permissions, I get "you do not sufficient permissions do do this" even
though I am logged in as root.

I tried all sorts of variations for the fstab entry for sda2 including
duplicating the hda2 entry (exdcept for the hda and mount point.) so
success. Also tried using the subfs with fs=ntfss just as a guess, but
could find no info on it and it also did not work. Is there a script for
the subfs daemon?

Could someone tell me what is going on and how I get user access to sda2
as user?

Art

--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


------------------------------------------

Jorge Manuel B. S. Vicetto
Network Manager and Systems Administrator
Angra do HeroĆ­smo Nursing School (ESEnfAH)

------------------------------------------

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.




< Previous Next >