Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
9.1 trashed my HD
  • From: Stewart Taylor <stewarta.taylor@xxxxxxxxxxxxxxx>
  • Date: Fri, 14 May 2004 20:02:47 +0100
  • Message-id: <200405142002.47896.stewarta.taylor@xxxxxxxxxxxxxxx>
Hi all

I've just completed an install of 9.1 Pro. After trashing my disk it took
nearly 2 days to sort out the disk and then re-install win98se, i have a duel
boot system at present and install 9.1..

Her's what happened and how I fixed it in case it happens to anyone elese.

On the initial install it went into a loop at the partitioning stage and kept
asking me what type of install I wanted to do. After a couple of loop
throughs I cancelled the install and tried again from scratch. This time
everything appeared to go as normal but when the install was completed the
partition sizes were incorrect and the Windows C & D drives were not
recognised. I booted intp win to see if there were any problems and that was
showing an un-formatted partition of 19GB, which actually didn't exist. When
I started up Partition Magic 7.0 it reported a partition table error, which
it refused to do anything about. I tried MS fdisk but that locked up. This
went on and on using different options and different sequences until I found
one that did work. This is the sequence that finally worked. Start a 9.1
install, when setting up the partitions set one partition for all the space
available, It was reporting the 80 GB drive as 12 GB by the way. Set the
format to ext2, no other worked, Once the file install started abort the
install. Run MS fdisk /mbr then MS fdisk and delete the non-dos partition
reported as 12 GB. Set a primary and extended partition and format to FAT 32.
Start partition magic, delete the partitions created in fdisk. create fat 32
partitions for windows and ext2 partitions for Linux. This finally sorted the
drive out and then I could install both win98se and 9.1 with no problems and
they are both running as they should now.

Prior to this both win98se and SUSe 8.0 pro were working correctly with no
apparent problems.

On a very positive note now that I have 9.1 installed it was well worth the
effort. A big improvment all round on 8.0.

Stewart

< Previous Next >
Follow Ups