Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Suse 9.1 installation on Adaptec Raid with dtp_i20 driver
  • From: Joseph Brockert <joe@xxxxxxxxxxxx>
  • Date: Wed, 12 May 2004 20:53:00 -0500
  • Message-id: <1084413179.3564.15.camel@xxxxxxxxxxxxxxxxx>
Mark,
I should have been more clear. SuSE 9.0 with the adaptec card installed
to any drive configuration(raid or no raid) by loading the dtp_i2o
driver at install time. And just like you it had "double vision" and
when the raid setup
fail I could not recover it. I then set it up without raid and it
worked but still had "double vision". I ran with it like that for
months, and like you I was unable to convince SuSE that they had a
problem. My hope was that it would be fixed in 9.1. But as I see the
problem is worse. 9.1 can't even find any drive configuration. Did I
answer your question?....joe


On Wednesday 12 May 2004 04:40 pm, Joseph Brockert wrote:
| Are you suggesting that when the yast probe finds the the raid card
| and and recommends loading the dpt_i2o driver that I say no and
| continue on?, or is their a setting on the card itself that I need to
| disable?....thanks joe
|
| On Wed, 2004-05-12 at 14:55, g.lams@xxxxxxxxxx wrote:
| > I had the same kind of problem on an "old" integrated and I had to
| > disable i2o on the raid adapter. I also had to pass 2 parameters at
| > boot time but disabling i2o could be enough
| >
| > gael
| >
| > --Joseph Brockert <joe@xxxxxxxxxxxx> wrote: --
| >
| > >To: suse-linux-e@xxxxxxxx
| > >From: Joseph Brockert
| > >Date: 12/05/2004 09:06PM
| > >Subject: [SLE] SuSE 9.1 installation on Adaptec Raid with dtp_i2o
| > >driver
| > >
| > >I boot to SuSE install dvd and start a manual install. Yast finds
| > > my adaptec(dtp) 2000 raid card and ask to load the dpt_i20
| > > drivers, I say
| > >OK. Yast continues but says it can find any hard disks. I know
| > > hards are
| > >installed, because I have formated them up, install SuSE 9.0, then
| > >reformated. This same process works OK with SuSE 9.0 installation.
| > >I
| > >have tried just installing to a single disk, or a raid setup, but
| > >the
| > >intallation never finds any disks. Can anyone give me an idea
| > > where to
| > >look next?.....joe


Gael,


I have a DPT PM2865U3, which is pretty much an Adaptec 21xxS RAID
controller with an Adaptec-ified BIOS on one of my personal
workstations. I also put several of these cards in clients' servers.


The card works flawlessly on SuSE 8.0, 8.1 and 8.2. On 9.0, the driver
got "double vision" and saw at least one hard disk twice. Only way to
install 9.0 was to create a hardware RAID1 array (but when one of the
drives died, SuSE freaked, so now I'm back to 8.2).


I was unable to convince SuSE that they had a problem here.


What parms did you pass to the driver to get it to work properly in 9.0?


Thanks,
Mark




< Previous Next >