Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] More about the latest Mantel 2.6.5 kernels [SOLVED]
  • From: eddie <eddie.howson@xxxxxxxxxxxxx>
  • Date: Wed, 12 May 2004 11:44:11 +0100
  • Message-id: <200405121144.12286.eddie.howson@xxxxxxxxxxxxx>
On Tuesday 11 May 2004 15:39, Mark wrote:
> eddie wrote:
> > I don't know if I've missed something or maybe they are not for SuSE 9.0
> > but when I try to install them I get a dependency failure.
> >
> > error: Failed dependencies:
> > /sbin/update-modules.dep is needed by kernel-default-2.6.5-12.1
> >
> > Is there something else that needs to be installed? If so, can someone
> > point me in the right direction, please? Is it safe to install it with
> > the --nodeps option?
>
> It appears to be a dependency issue arising from the kernel expecting
> something that is in aaa_base for 9.1 but not for 9.0. The following
> hack is taken from alt.os.linux.suse. Installing this "rpm" works
> because I've done it, though whether it's a good idea or not is another
> matter. The person who posted it said that he subsequently had recent
> 2.6 Mantel kernels working fine, though I've never yet had one work on
> my installation. It does look as if recent kernels of the day are
> intended for 9.1 but I've really no idea.
>
> :)
>
> Fish
> ______________________
>
> build an rpm package.
>
> 1. get aaa_base-*.i586.rpm from the 9.1 updates
> 2. Fire up mc (Midnight Commander), open that rpm, and
> copy /sbin/update-modules.dep to /usr/src/packages/SOURCES
> 3. Copy the next spec file to /usr/src/packages/SPECS
> 4. cd /usr/src/packages/SPECS
> 5. rpmbuild -ba update_modules_dep.spec
> 6. rpm -Uhv /usr/src/packages/RPM/noarch/update_modules_dep-*.rpm
> 7. install the new kernel rpms
>
> Works for me, but this is only the forst time I booted with this kernel
> (2.6.5-10.58)
>
> Cheers,
>
> Leen
>
> Here's the spec file:
> ,----[ /usr/src/packages/SPECS/update_modules_dep.spec ]
>
> | Name: update_modules_dep
> | License: GPL|BSD
> | Group: None
> | Summary: Provide update-modules.dep script
> | Packager: Leendert Meyer <leen.meyer@xxxxxxx>
> | Version: 0.0.1
> | Release: 0
> | Source0: update-modules.dep
> | BuildRoot: %{_tmppath}/%{name}-%{version}-build
> | BuildArch: noarch
> |
> | %description
> | Provide update-modules.dep script from 9.1's aaa_base
> |
> | %prep
> |
> | %build
> |
> | %install
> | rm -rf %buildroot
> | install -d -m 755 %buildroot/sbin
> | install -m 755 -o root -g root %{SOURCE0} %buildroot/sbin
> |
> | %clean
> | rm -rf %buildroot
> |
> | %files
> | /sbin/update-modules.dep
> |
> | %changelog -n update_modules_dep
> | * Sat May 08 2004 - leen.meyer@xxxxxxx
> | - 0.0.1-0: Initial package
>
> `----
>
>
>
> #EOF

Thanks Mark,

That seems to have done the trick.

Eddie

< Previous Next >
This Thread
References