Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
RE: [SLE] PHP Globals not working on 9.0 ??
  • From: "Berge, Harry ten" <berge@xxxxxxx>
  • Date: Wed, 12 May 2004 08:06:19 +0200
  • Message-id: <8C6ADF4772B7D511A3E40008C7BB878A014E5C2C@xxxxxxxxxxxxxx>
PHP globals are turned off (by default) on SUSE 9.x. This is because they
are a security risk. If you want to enable PHP globals change the variable
'register_globals' to 'On' in /etc/php.ini


Regards Harry

-----Original Message-----
From: David Rankin [mailto:drankin@xxxxxxxxxxxxxxxx]
Sent: woensdag 12 mei 2004 7:17
To: Suse Linux
Subject: [SLE] PHP Globals not working on 9.0 ??


Mates,

I have a weird situation. Suse Pro 9.0. I'm trying to get the following
simple php script to work as I start working on basic authentication, but
the AUTH_USER and AUTH_PW globals never seem to get set. What is funny is
that the script works just fine on my ancient mdk 7.2 box. Anybody
experience any similar problems? Any gotchas unique to the suse install I'm
missing?? You can check my phpinfo at 3111skyline.com/test.php. I don't know
what do check next.

<?php

if ((!isset( $PHP_AUTH_USER )) || (!isset($PHP_AUTH_PW))) {

header( 'WWW-Authenticate: Basic realm="Private"' );
header( 'HTTP/1.0 401 Unauthorized' );
echo 'Authorization Required.';
exit;

} else {

echo "You entered $PHP_AUTH_USER for a username.<BR>";
echo "You entered $PHP_AUTH_PW for a password.<BR>";

}

?>

--
David C. Rankin, J.D., P.E.
Rankin * Bertin, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
(936) 715-9333
(936) 715-9339 fax
www.rankin-bertin.com
--


--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >
Follow Ups