Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
SUSE 9.1 & Firewire harddrive
  • From: Art Fore <afore@xxxxxxxxx>
  • Date: Tue, 11 May 2004 21:40:26 -0700
  • Message-id: <1084336825.6793.51.camel@xxxxxxxxxxxxxx>
Having problems with Firewire harddrive that worked in SUSE 9.0 Here is
info belo.

NOTE: was having problems of unmounting hda2 and firwire drives after
being accessed by Konqueror, would say drive was busy. Only way to
unmount was to kill konqueror instead of closing it. YOU upgraded kernel
to 2.6.4-54.5 fixed this plus an error during booting about PCI modules.

fstab entries
/dev/hda7 / reiserfs
acl,user_xattr 1 1
/dev/hda6 /data1 reiserfs
acl,user_xattr 0 0
/dev/hda2 /windows/C ntfs
ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda5 swap swap
pri=42 0 0
devpts /dev/pts devpts
mode=0620,gid=5 0 0
proc /proc proc
defaults 0 0
usbfs /proc/bus/usb usbfs
noauto 0 0
sysfs /sys sysfs
noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs
fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/sda2 /Firewire/winc ntfs
ro,noauto,users,uid=afore,gid=users,umask-0002 0 0
/dev/sda6 /Firewire/linux reiserfs
noauto,uid=afore,gid=users 0 0

After plugging in the firewire drive, I get the following entries added
to the mtab file.

/dev/sda6 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p6 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda3 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p3 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda5 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p5 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda1 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p1 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda2 /media/ieee1394_sbp2-0030e001e001b2bb-0-0p2 subfs
rw,noexec,nosuid,nodev,sync,fs=floppyfss,procuid 0 0

sda1 is the only folder I can open. All of the other folders come up
"cannot enter folder". Same as root. Strange thing to me is they all
show fs-floppyfss, however, sda1 is fat-32, sda2 is ntfs, sda6 is
reiserfs

I then mount /dev/sda2 /Firewire/winc and dev/sda6 /Firewire/linux, I
get the following added to the mtab file

/dev/sda2 /Firewire/winc ntfs rw 0 0
/dev/sda6 /Firewire/linux reiserfs rw 0 0

I notice the sda2 is rw in both the /media and /Fire/winc entries.

I can access /Firewire/linux (sda6) a user, no problem.

I can access /Firewire/winc (sda2) only as root and I cannot change
permissions to allow users to view the directory. Trying to change
permissions, I get "you do not sufficient permissions do do this" even
though I am logged in as root.

I tried all sorts of variations for the fstab entry for sda2 including
duplicating the hda2 entry (exdcept for the hda and mount point.) so
success. Also tried using the subfs with fs=ntfss just as a guess, but
could find no info on it and it also did not work. Is there a script for
the subfs daemon?

Could someone tell me what is going on and how I get user access to sda2
as user?

Art

< Previous Next >