Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] SuSE 9.1: samba problem...
  • From: Frederic Soulier <frederic@xxxxxxxxxxxxxxxxxxx>
  • Date: Tue, 11 May 2004 22:37:54 +0100
  • Message-id: <1084311473.8411.37.camel@xxxxxxxxxxxxxxx>
On Tue, 2004-05-11 at 22:09, Pieter Hulshoff wrote:
> On Tuesday 11 May 2004 23:01, Frederic Soulier wrote:
> > I'm trying to access shares on my linux box from a WinXP box.
> > On both boxes I use the same username/password.
> > I added the username/password with "smbpasswd -a frederic" on the linux
> > box.
>
> Well, a few things might have changed in Samba 3 that give your setup some
> problems. I presume you've checked that smb is actually running. Have you
> tried setting it up from Yast2?

Worked fine with Samba 3 on MDK 10.0 :)

> I noticed you're using @users for the valid users, while the Yast2 generated
> config file uses %S.
>
> Also: make sure the user frederic exists on your Linux machine, and has access
> to the file. Otherwise the user will probably be mapped to guest, which means
> the 'other' permissions for the directories and files have to be set properly
> (also doable).

I used YAST2 and compared smb.conf before and after and here are the
differences:

YAST2 added bits and pieces to different sections as follows:

[global]
passdb backend = smbpasswd
add machine script =
domain master = false
domain logons = no
ldap suffix = dc=example,dc=com

[homes]
guest ok = no
printable = no

[floppy]
guest ok = no
printable = no

[dvdrecorder]
guest ok = no
printable = no

[cdrecorder]
guest ok = no
printable = no


Now "smbclient -L localhost" gives:
frederic@wallaby:~> smbclient -L localhost
Password:
Domain=[WALLABY] OS=[Unix] Server=[Samba 3.0.2a-SUSE]

Sharename Type Comment
--------- ---- -------
floppy Disk Floppy on (localhost)
dvdrecorder Disk DVD-RW on (localhost)
cdrecorder Disk CD-RW on (localhost)
IPC$ IPC IPC Service (Linux Samba Server
3.0.2a-SUSE on (localhost))
ADMIN$ IPC IPC Service (Linux Samba Server
3.0.2a-SUSE on (localhost))
canon_i865 Printer Canon i865
frederic Disk Home Directories
Domain=[WALLABY] OS=[Unix] Server=[Samba 3.0.2a-SUSE]

Server Comment
--------- -------

Workgroup Master
--------- -------
HOME WALLABY


and my WinXP box sees the shares.


Thanks for suggesting YAST2 it was the obvious thing to try first.
--
Frederic Soulier <frederic@xxxxxxxxxxxxxxxxxxx>


< Previous Next >