Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
mount quirkyness
  • From: Marshall Heartley <marshall.heartley@xxxxxxxxxxxxx>
  • Date: Tue, 11 May 2004 06:39:59 -0400
  • Message-id: <1084271999.5447.15.camel@xxxxxxxx>
This I feel needed a separate thread because it is a different issue
than the thread I started called Cannot create hard drive icons.

I got a 19G partition that I am trying to access. The file system is
reiser. I can mount it and umount it from the command line just fine
but it is when I try and do it through either KDE or GNOME that I run
into issues.

I created the desktop icon for the drive and click on it. It mounts
successfully and I am able to carry out read/write operations to the
disk. But I close the konqueror window and try to umount it by right
clicking on the icon and choosing unmount, I get the error that the
drive cannot umount because it is still busy. Well looking at the
processes, I see that konqueror did not completely die. I kill it and
then I am able to umount successfully.

Now in Gnome, I right click on the desktop and choose in the disk menu
the drive that I want to mount, it mounts and I see the icon on the
desktop. But if I immediately try to umount it or even after working
with the drive try and umount it, Gnome freezes up completely! Hard! I
needed to do a reboot in order to gain access to my machine.

Can anyone give me any clues on why this is? I would appreciate it!

Ok here is the 2 variations I tried in the fstab file and both have the
same outcomes.

Original one I put in:

/dev/hdb2 /mydata reiserfs user,noauto,acl,user_xattr 0 0

One that I have now:

/dev/hdb2 /mydata reiserfs user,noauto 0 0

Thanks!

Marshall



< Previous Next >
Follow Ups