Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Quake - having problems finding libraries
  • From: Robert Pollard <robertmp@xxxxxxxxxxx>
  • Date: Mon, 10 May 2004 22:24:26 -0700
  • Message-id: <200405102224.26161.robertmp@xxxxxxxxxxx>
Hello all,

I get the following message when trying to launch Quake:
Q3 1.11 linux-i386 Nov 24 1999
----- FS_Startup -----
Current search path:
/home/rpollard/.q3a/baseq3
./baseq3/pak0.pk3 (3539 files)
./baseq3

----------------------
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: linux.local
Alias: linux
IP: 127.0.0.2
----- R_Init -----
...loading libGL.so: QGL_Init: Can't load libGL.so from /etc/ld.so.conf or
current dir: /usr/local/games/quake3/libGL.so: cannot open shared object
file: No such file or directory
failed
...loading libMesaVoodooGL.so: QGL_Init: Can't load libMesaVoodooGL.so from /
etc/ld.so.conf or current dir: /usr/local/games/quake3/libMesaVoodooGL.so:
cannot open shared object file: No such file or directory
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Error: GLimp_Init() - could not load OpenGL subsystem

I have SUSE Linux 9.0, AMD Athlon XP 1800+

Any ideas? I figured there is something easy that has to be done to tell
Quake where the libraries are.

Thanks,

Robert Pollard


< Previous Next >
Follow Ups