Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Scanning problem in 9.1
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Sun, 09 May 2004 13:41:17 +0100
  • Message-id: <409E26ED.6010003@xxxxxxxxxxxxxxxx>
Keith Powell wrote:

Version 9.0 worked almost "out of the box" with very few tweaks required. However, I have been trying 9.1 and am having all sorts of problems with it.

For example, a clean install gives me the error message:

bash: /dev/nul: permission denied (this line three times)

whenever I run a terminal.
This has been sorted by my altering the dev/nul permissions. However, there are still several error messages whenever I try to run anything from the terminal. Not had this happen before!

However, the main problem I have found is that I can't get my Epson 1240U scanner to work. SUSE 9.0 found it and it worked perfectly.

If I run xsane or xscanimage, they can't find the scanner. So I have set it up with YAST (installation didn't find it!). If I run xsane as a user, it still can't find the scanner. However, using a terminal and ignoring all the error messages, if I run xsane as ROOT, it runs and scans. After that, I can run it as a user until I shut down the computer. When I start the computer again, I have to run xsane as ROOT again before I can run it as a user. Very frustrating!

I have re-installed 9.1 three times, and each time I get the same problems. I then did a clean installation of 9.0. Everything (including the scanner) worked. But after an upgrade, the scanner had disappeared again and I was back to manually installing it and running ROOT first.

I have checked and re-checked permissions in xsane, sane.d and the epson config file in sane.d. They are all OK.

Also, I have installed all the patches.
I'm lost! Has anyone else come across this problem, please?

Many thanks

Keith


Oh boy! this sounds very strange. When you said clean install, I take it that it included reformatting the partitions. If it weren't for the 9.0 install being fine, I'd have said it was hardware as I recently had similar problems when I changed CPU/mobo/mem and it turned out to be a bad CPU. The suspicion has to fall on the install media, with 9.0 I found I couldn't install from the DVD and I had some problems with CD2 till with a struggle I got it to make a copy which worked OK. It also could be my CD-RW/DVD on this box, however, I shall see what happens when I get around to upgrading the 32-bit laptop (CD-only) and this 32-bit box. Yesterday I successfully upgraded one laptop from 9.0 x86_64 Pro to 9.1 x86_64 Pro with only one funny where grub is looking in /usr/lib for the stage files, I copied them from /boot/grub into /usr/lib and that fixed it, I shall have a look at "man/info grub" for clues. I am also running on the kernel.org 2.6.5-mm2 kernel which I was using previous to the upgrade.
Have you tried both the CD's and the DVD's?
Regards
Sid.

--
Sid Boyce .... Hamradio G3VBV and keen Flyer
Linux Only Shop.


< Previous Next >
Follow Ups
References