Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Scanning problem in 9.1
  • From: Keith Powell <keith@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Sun, 9 May 2004 12:53:05 +0100
  • Message-id: <200405091253.05767.keith@xxxxxxxxxxxxxxxxxxxxxxx>
Version 9.0 worked almost "out of the box" with very few tweaks required.
However, I have been trying 9.1 and am having all sorts of problems with it.

For example, a clean install gives me the error message:

bash: /dev/nul: permission denied (this line three times)

whenever I run a terminal.

This has been sorted by my altering the dev/nul permissions. However, there
are still several error messages whenever I try to run anything from the
terminal. Not had this happen before!

However, the main problem I have found is that I can't get my Epson 1240U
scanner to work. SUSE 9.0 found it and it worked perfectly.

If I run xsane or xscanimage, they can't find the scanner. So I have set it up
with YAST (installation didn't find it!). If I run xsane as a user, it still
can't find the scanner. However, using a terminal and ignoring all the error
messages, if I run xsane as ROOT, it runs and scans. After that, I can run it
as a user until I shut down the computer. When I start the computer again, I
have to run xsane as ROOT again before I can run it as a user. Very
frustrating!

I have re-installed 9.1 three times, and each time I get the same problems. I
then did a clean installation of 9.0. Everything (including the scanner)
worked. But after an upgrade, the scanner had disappeared again and I was
back to manually installing it and running ROOT first.

I have checked and re-checked permissions in xsane, sane.d and the epson
config file in sane.d. They are all OK.

Also, I have installed all the patches.

I'm lost! Has anyone else come across this problem, please?

Many thanks

Keith

< Previous Next >