Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Proper netmask configuration?
  • From: Dylan <dylan@xxxxxxxxxxx>
  • Date: Mon, 3 May 2004 22:50:28 +0100
  • Message-id: <200405032250.29162.dylan@xxxxxxxxxxx>
On Monday 03 May 2004 22:35 pm, James D. Ivey wrote:
> I don't believe my network is configured properly, but I've tried
> everything I can think of to fix it.
>
> "ifconfig" says the following about eth0:
> inet addr:192.168.1.5 Bcast:192.168.1.255 Mask:255.255.255.255
>
> The netmask should be 255.255.255.0.

Indeed it should

>
> Under YaST2, eth0 is shown to have static address setup with an
> address of 192.168.1.5 and a subnet mask of 255.255.255.0. Under
> "routing", I can only specify the gateway address (which is correctly
> specified), but I cannot specify a correct subnet mask.
>
<SNIP>
> I've tried manually overriding with ifconfig and other CLI tools.
> However, my Internet access (and all network access) stops when I do
> that. It's only when I go back to YaST2 that I regain that access,
> but then ifconfig reports the incorrect netmask as described above.

How are you connecting to the internet?

Dylan

--
"I see your Schwartz is as big as mine"
                                  -Dark Helmet

< Previous Next >
Follow Ups
References