Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Fetchmail Problem
  • From: Jesse Shaver <J_shaver@xxxxxxxxxxx>
  • Date: Wed, 17 Mar 2004 18:08:58 -0800
  • Message-id: <20040318020858.GA12914@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
I have Fetchmail set up to run in Cron with the command ./usr/bin/fetchmail -sa > /dev/null 2>&1.. Every so often (3 times this week, but that is more frequent than it has been in the past) I realize that I have not received any email from the SuSE list in an unusually long amount of time. So I run Fetchmail manually. Often times I get this error message:

3 messages for j_shaver at mail.comcast.net (11629 octets).
reading message j_shaver**AT**mail.comcast.net:1 of 3 (425 octets) fetchmail: message delimiter found while scanning headers
fetchmail: timeout after 60 seconds.
fetchmail: client/server synchronization error while fetching from Comcast.net
fetchmail: Query status=7 (ERROR)

So I log into Comcast web mail and find a malformed message like this one (all headers are included below):

> Date: Thu, 18 Mar 2004 00:47:16 +0000 (GMT)
> X-Comment: Sending client does not conform to RFC822 minimum requirements
> X-Comment: Date has been added by Maillennium
> Received: from 200-153-199-126.dsl.telesp.net.br ([200.153.199.126])
> by sccrmxc11.comcast.net (sccrmxc11) with SMTP
> id <20040318004638s110067fhke>; Thu, 18 Mar 2004 00:47:13 +0000
> X-Originating-IP: [200.153.199.126]
> Message-ID: <s[9

that is it. In the past I have tried to download these messages with Eudora, and it has been able to get them just fine, so I don.t know what is wrong. I realize that this is a malformed email, but I would like Fetchmail to get it anyways, and then filter it out with Procmail or something. Short of that, I would just like to set stuff up in such a way that Fetchmail does not fail silently, so at least I don.t have to guess when things are failing. I am Running SuSE 8.1 Pro, and am up to date on updates. Any suggestions would be appreciated.

thanks in advance,

--
Jesse Shaver


< Previous Next >