Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Re: [SLE] help with IMAP
  • From: "Joe Morris (NTM)" <Joe_Morris@xxxxxxx>
  • Date: Sun, 07 Mar 2004 12:43:38 +0800
  • Message-id: <404AA87A.8050407@xxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 03/07/2004 11:40 AM, linuxjim wrote:

|I guess I'm unclear on this. I had assumed that when imap is running, I
can
|access my normal user mail folders thru imap, leaving folders where
they are,
|e.g. "home/<username>/mail". Is this what you are saying?

Yes, except Linux is case sensitive, so it would be Mail.
~<username>/Mail/ is the same (sorry I missed a slash and added one in
the wrong place.) That is the setup on the IMAP account I have in my
client. That way I can go into any users account in our server via imap
just by changing the username, username element of the path, and
password (usually to delete or forward email).

|I did revise the client settings to reflect the change to port 993 and
using
|SSL, but not StartTLS.

That should be correct.

|Regarding the certs, keep in mind that I have postfix running on
host.local.

As far as imapd is concerned, postfix is not part of the equation.

|I set up a host name to listen on this comuters local IP address. That
is why I
|originally issued 2 different certs, one for the domain.com name, and
another
|for the local (internal) IP address. But, as stated earlier I deleted both
|and re-issued one for imapd.pem. Still not connecting.

What are you putting in as the server name. Unless you run a local DNS,
I would suggest just using the IP, i.e. 192.168.1.1

|When I had imap running, I could telnet to it at port 143 and get a
reply. Now
|that imaps is running when I telnet to port 993 I get only a blinking
cursor.
|If I press any key, it exits back to the local telnet prompt, no visible
|reply from imapd.

What happens if you ssh? My guess is telnet does not use ssl and
therefore will not work. I don't really know, as I just use a mail
client. It will ask you to accept the certificate (because it is
self-signed and not automatically trusted, i.e. not issued by a known
and trusted Certificate Authority), which since I trust it I accept it
permanently. It will then work without asking again. What mail client
have you tried?

- --
Joe Morris
New Tribes Mission
Email Address: Joe_Morris@xxxxxxx
Web Address: http://www.mydestiny.net/~joe_morris
Registered Linux user 231871
God said, I AM that I AM. I say, by the grace of
God, I am what I am.




-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2-rc1-SuSE (GNU/Linux)
Comment: Using GnuPG with Netscape - http://enigmail.mozdev.org

iD8DBQFASqh5Z1XBlLwwaC0RAu0HAJ4taHzUbVUj5Vkj0g6pTDuUrv5fOACfbM7b
o2Kx5thIjSEyJpk5F8BhCEc=
=RZPe
-----END PGP SIGNATURE-----



< Previous Next >