Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Re: [SLE] cdrecord stopped working
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Thu, 04 Mar 2004 19:47:44 +0000
  • Message-id: <404787E0.7020606@xxxxxxxxxxxxxxxx>
Martin Mielke wrote:

Hi all,

please see my reply inline...


Anders Johansson wrote:

On Monday 01 March 2004 11.39, Martin Mielke wrote:

Hello there,

I have the same problem but results are different at my side.
After I installed SuSE 9.0 Pro, everything worked fine: cdrecord, kooka,
digital camera, etc... then suddenly things stopped working one by one. In
some cases, I still could use them as root (i.e.: cdrecord) but now not
even root can do much with those devices/utils...

I did the "resmgr login <username> :0" and it returned a "sucess" - but
cdrecord still doesn't work for neither my user (martin) nor root ... :-/

As root I issued a 'cdrecord -scanbus' and got all this crap on
/var/log/messages:


<snip>

Which is quite weird, as I haven't messed up with the modules or the
CDRW-device itself... yet.

Information on this will be much appreciated!



Try "cdrecord dev=ATAPI: -scanbus"

That's what I need to do to get it to work without ide-scsi


I tried your suggestion as root and... oops! more weirdness...

See pasted text:

---

hexe:~ # cdrecord dev=ATAPI: -scanbus
Cdrecord-Clone 2.01a18-dvd (i686-suse-linux) Copyright (C) 1995-2003 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to <warly@xxxxxxxxxxxxxxxx>.
Note: The author of cdrecord is not to be bothered with problems in this version.

There was a problem with 2.6.x kernels which has been resolved. There was quite a bit of vitriol on the kernel mailing list about this some time ago, looks like Jorg relented and later versions work. Grab the latest from freshmeat.net, "tar jxfv cdrtools-2.01a26.tar.bz2", "cd cdrtools-2.01", "Gmake", Gmake INS_BASE=/usr install" and enjoy.
barrabas:/ftp/mar04 # cdrecord dev=ATAPI: -scanbus
Cdrecord-Clone 2.01a26 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
scsidev: 'ATAPI:'
devname: 'ATAPI'
scsibus: -1 target: -1 lun: -1
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.8'.
scsibus0:
0,0,0 0) *
0,1,0 1) 'ATAPI ' 'COMBO48XMAX ' '1.10' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
Regards
Sid.

--
Sid Boyce .... Hamradio G3VBV and keen Flyer
Linux Only Shop.


< Previous Next >