Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Re: [SLE] cdrecord stopped working
  • From: Martin Mielke <martin.mielke@xxxxxxxxxxxxx>
  • Date: Thu, 04 Mar 2004 18:43:17 +0100
  • Message-id: <40476AB5.9030009@xxxxxxxxxxxxx>
Hi all,

please see my reply inline...


Anders Johansson wrote:

On Monday 01 March 2004 11.39, Martin Mielke wrote:

Hello there,

I have the same problem but results are different at my side.
After I installed SuSE 9.0 Pro, everything worked fine: cdrecord, kooka,
digital camera, etc... then suddenly things stopped working one by one. In
some cases, I still could use them as root (i.e.: cdrecord) but now not
even root can do much with those devices/utils...

I did the "resmgr login <username> :0" and it returned a "sucess" - but
cdrecord still doesn't work for neither my user (martin) nor root ... :-/

As root I issued a 'cdrecord -scanbus' and got all this crap on
/var/log/messages:

<snip>

Which is quite weird, as I haven't messed up with the modules or the
CDRW-device itself... yet.

Information on this will be much appreciated!


Try "cdrecord dev=ATAPI: -scanbus"

That's what I need to do to get it to work without ide-scsi


I tried your suggestion as root and... oops! more weirdness...

See pasted text:

---

hexe:~ # cdrecord dev=ATAPI: -scanbus
Cdrecord-Clone 2.01a18-dvd (i686-suse-linux) Copyright (C) 1995-2003 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to <warly@xxxxxxxxxxxxxxxx>.
Note: The author of cdrecord is not to be bothered with problems in this version.
scsidev: 'ATAPI:'
devname: 'ATAPI'
scsibus: -1 target: -1 lun: -1
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) *
cdrecord: Warning: controller returns wrong size for CD capabilities page.
0,1,0 1) 'CREATIVE' 'CD5233E ' '1.00' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
scsibus1:
1,0,0 100) 'ATAPI ' 'CD-R/RW 12X8X32 ' '9.EB' Removable CD-ROM
1,1,0 101) *
1,2,0 102) *
1,3,0 103) *
1,4,0 104) *
1,5,0 105) *
1,6,0 106) *
1,7,0 107) *

---

That's killing me... my CD-RW device has always been dev=0,0,0 -- and I swear I haven't messed up the wires inside my box.
Furthermore, assuming that dev=1,0,0 would work is false, as I already tried it and stumbled again... so by now I can't burn CDROMs, which is starting to be quite annoying...

Suggestions?

Thanks in advance and regards,
Martin


< Previous Next >