Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
RE: [SLE] Help Installing SuSE 9 AMD64 Apache2 rpms with yast2 on SLES 8 AMD64
  • From: "Richard Mixon (qwest)" <rnmixon@xxxxxxxxx>
  • Date: Tue, 2 Mar 2004 08:58:38 -0700
  • Message-id: <DKELJBPNDHJEECCAEPGOOEAEELAA.rnmixon@xxxxxxxxx>
Peter/all,

Thanks for the link to the apache2 info and the FAQ on Apache2. There do indeed seem to be Apache2 RPMs for United Linux 1.0 on
AMD64.

I have one more question. My install (with online updates) of SLES 8 for AMD64 already has the file /etc/sysconfig/apache2 for
configuring Apache2.

Is there someplace I can put the RPMs from ftp://ftp.suse.com/pub/suse//pub/projects/apache/apache2/ul1-x86_64
so that the Yast2 Install and Remove Software function will pick these up and do the additional dependency checking that it appears
to do?

Thank you again - Richard

-----Original Message-----
From: poeml@xxxxxxxx [mailto:poeml@xxxxxxxx]On Behalf Of
poeml@xxxxxxxxxxx
Sent: Tuesday, March 02, 2004 3:41 AM
To: suse-linux-e@xxxxxxxx
Subject: Re: [SLE] Help Installing SuSE 9 AMD64 Apache2 rpms with yast2
on SLES 8 AMD64


On Mon, Mar 01, 2004 at 05:02:47PM -0700, Richard Mixon (qwest) wrote:
> (I posted this on the suse-amd64 list, then got to thinking, this is more a general SuSE question - apologies for the double post
:)
>
> I am sure this is a SuSE yast2 newbie problem. But I have read and re-read the SLES 8 for AMD64 installation manual, The SuSE 9.0
> installation manual and I have Googled for hours already. Help is appreciated.
>
> The specific problem is with Apache2, but I believe I should be using yast2 for all of my RPM installs, if I understand correctly.
>
> I downloaded the Apache2 rpms for SuSE 9.0 AMD64 from SuSE'S ftp site, expecting/hoping to be able to install them on my SLES 8
for
> AMD64 server. Here they are:
> apache2-2.0.48-24.x86_64.rpm
> apache2-devel-2.0.48-24.x86_64.rpm
> apache2-doc-2.0.48-24.x86_64.rpm
> apache2-example-pages-2.0.48-24.x86_64.rpm
> apache2-jakarta-tomcat-connectors-4.1.27-132.x86_64.rpm
> apache2-metuxmpm-2.0.48-24.x86_64.rpm
> apache2-mod_auth_mysql-20030510-99.x86_64.rpm
> apache2-mod_fastcgi-2.4.0-132.x86_64.rpm
> apache2-mod_macro-1.1.4-95.x86_64.rpm
> apache2-mod_perl-1.99_09_20030807-89.x86_64.rpm
> apache2-mod_php4-4.3.3-101.x86_64.rpm
> apache2-mod_python-3.0.3-131.x86_64.rpm
> apache2-mod_ruby-1.1.1-92.x86_64.rpm
> apache2-prefork-2.0.48-24.x86_64.rpm
> apache2-worker-2.0.48-24.x86_64.rpm
>
> Well of course I'm running into dependency problems. So I figure I would use yast2's "Install or Remove Software" option.
>
> So the first task was setting to use the "Change Source of Installation" to point at the the right directory - in my case
> /opt/software/apache2.
> Well when I try and add a "local directory" installation source it tells me:
> Error - Unable to create installation source from
> URL 'dir:///opt/software/apache2/'.
> Details:
> ERROR(InstSrc: E_non_instsrc_on_media)
>
> Is there some reasonably straightforward organization that the source directory needs to be in?
>
> I've tried using "yast2 -i apache2-2.0.48-24.x86_64.rpm". It installs the package with no complaints. I run an 'rpm -qa | egrep
> "apache2"' and it appears installed fine. But when I start up yast2 Install GUI for something else, it shows me all kinds of
> dependency problems.

http://www.suse.com/~poeml/apache-faq.html#depend2

Install at least apache2, apache2-prefork and libapr0.

Peter



< Previous Next >
References