Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] Acer/Benq S2W 3300 not working
  • From: FX Fraipont <fxf@xxxxxxxxx>
  • Date: Fri, 30 May 2003 17:13:10 +0100
  • Message-id: <3ED78316.9000001@xxxxxxxxx>
Sourian wrote:

I tried all from Benq section. I also tried all from Agfa, as I read on
the net that Acer S2W 3300U is a derivate from an Agfa model (still I
don't know from which one).

So I started with that article from knowledge database:

Step 1.: sane-find-scanner

sane-find-scanner

# No SCSI scanners found. If you expected something different, make
sure that
# you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a5, product=0x20b0) at /dev/usb/scanner0
found USB scanner (vendor=0x04a5, product=0x20b0) at /dev/usbscanner
found USB scanner (vendor=0x05a9, product=0xa511) at libusb:001:002
found USB scanner (vendor=0x04a5, product=0x20b0) at libusb:001:003
# A USB device was detected. This program can't be sure if it's really
# a scanner. If it is your scanner, it may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Scanners connected to the parallel port or other proprietary ports
can't be
# detected by this program.

# You may want to run this program as root to find all devices. Once
you
# found the scanner devices, be sure to adjust access permissions as
# necessary.

Step 2.: scanimage -L

scanimage -L
device `snapscan:/dev/usb/scanner0' is a Acer FlatbedScanner22 flatbed
scanner
device `snapscan:/dev/usbscanner' is a Acer FlatbedScanner22 flatbed
scanner

Step 3: xscanimage

I get a popup windows: Failed to open device
`snapscan:/dev/usb/scanner0: Invalid argument.

I tried to restart the USB service /sbin/rchotplug restart, it restarts
fine, but scanner still not working.


All good news: we're getting closer.
Use your driver CD from acer, and find the firmware . Mine is on file:/media/cdrom/drivers/BIN/
ant I think it is
U126V043.BIN

and copy it to /etc/ for instance

Then edit /etc/sane.d/snapscan.conf


# Change to the fully qualified filename of your firmware file, if
# firmware upload is needed by the scanner
firmware /path/to/your/firmware/file.bin So /etc/U126V043.BIN

# If not automatically found you may manually specify a device name.

# For USB scanners also specify bus=usb, e.g.
# /dev/usb/scanner0 bus=usb UNCOMMENT this so
/dev/usb/scanner0 bus=usb


Then retry
sane-find-scanner

Scaninmage -L

Xsane


fx


--
______________________
Courtesy of SuSE Linux
http://www.nibz.org



< Previous Next >