Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
gcc versions 3.2 and 2.95
  • From: Arthur Magill <magill@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Wed, 28 May 2003 19:29:56 +0000
  • Message-id: <200305281929.57187.magill@xxxxxxxxxxxxxxxxxxxxxxx>
Hello all,

I'm running suse 8.1, and have finally got fed up with all those older
applications that don't compile with gcc version 3. So, I'd like to install
the older gcc 2.95, while keeping my current gcc 3.2. I've naively downloaded
an old tarball, and tried to build it. Trouble is, version 3.2 won't build
2.95 (yes, that's exactly the problem I'm trying to fix!). I tried to build
using:

./configure --program-suffix=-2.95 (that went okay)
make install (that broke)

I also tried:

make bootstrap

but that broke too. I won't include the errors - there were lots of them! The
usual sort of thing, about deprecated syntax, etc.

There must be lots of you out there who've managed to do this build? How did
you do it? Any ideas would be much appreciated.

Thanks in advance,

Arthur

< Previous Next >
Follow Ups