Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] YaST insanity
  • From: Andre Truter <andre.truter@xxxxxxxxxxxxx>
  • Date: 28 May 2003 05:56:20 +0200
  • Message-id: <1054094179.17768.392.camel@xxxxxxxxxxxxxxxxxx>
On Wed, 2003-05-28 at 02:25, Steve Miller wrote:
> Hi,
>

> Second, I tred downloading the SuSE RPM (SANE 1.0.10)
> from the SuSE 8.2 ftp site. I first was unable to
> change my installation medium to my home directory to
> install the package. So then I tried rpm -i
> blahblah.rpm. I got a message that the package could
> "not be installed". Using --install got the same
> result.
>
> How can I either (a) get YaST to behave or (b) install
> the software I need so YaST will realize that SANE IS
> installed and I can configure my scanner or (c) find a
> how-to that will tell me how to do manually whatever
> YaST is set up to do? YaST is blocking me at the
> software installation level and I am sure will block
> me at the configuration level even if I do get the
> software installed.

You can try to install the package with Yast, like this:

# yast2 -i /path/to/package/package.rpm

Or you can try the manual way:

rpm -Uvh /path/to/package/package.rpm

If you already have a version of the package installed, you need to
upgrade the package and not install it.

I use rpm -Uvh by default, that way new package is installed and an
existing one is upgraded.

HTH
--

Andre Truter
Software Engineer
Registered Linux user #185282
ICQ #40935899 AIM: trusoftzaf
http://www.trusoft.za.net

<------------------------------------------------->
< The box said: Requires Windows 95 or better... >
< So I installed Linux >
<------------------------------------------------->



< Previous Next >
Follow Ups
References