Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] Installing RPMs - path (newbie)
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Thu, 8 May 2003 14:32:02 +0200
  • Message-id: <200305081432.02684.andjoh@xxxxxxxxxx>
On Thursday 08 May 2003 10:29, Chris Grainer wrote:
> On Thu, 2003-05-08 at 01:18
>
> > Chris Grainer wrote:
> > > I am using SUSE 8.2 and I often get error messages like this when
> > > attempting to install rpm packages:
> > > I don't know where glib is and I haven't been able to find it. And if I
> > > did know where it was, I don't know how to indicate that in a command
> > > line
> >
> > .James Ogley wrote:
> >
> > Install glib-devel then try again
>
> Almost there, I think, installed glib-1.2.10-ximian.6.i386 and
> glib-devel-1.2.10-ximian.6.i386. Ran "rpm -i gnpan-0.13.4-0.src.rpm".
> And pkg-config was asked for. Installed pkgconfig-0.15.0tar.gz, "ran -i
> gnpan again" and got this:

Where are you getting ximian packages for 8.2? I didn't think they had started
releasing packages for 8.2 yet.

Second, you don't get any messages like that when you install a src.rpm, those
are compile errors.

And you don't have to reinstall the src.rpm every time you install a
dependency.

> No package 'glib-2.0' found

> "linux:/home/chris/downloads # rpm -Uvh glib2-2.2.1-1.i386.rpm
> package glib2-2.2.1-18 (which is newer than glib2-2.2.1-1) is already
> installed"

glib2-devel is needed. If you're going to compile a program that needs package
foo to run, you need foo-devel to compile it.


< Previous Next >
Follow Ups