Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] balsa refuses to launch acrobat or any other program [solved?]
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Tue, 6 May 2003 14:14:26 +0200 (CEST)
  • Message-id: <Pine.LNX.4.44.0305061401410.24305-100000@xxxxxxxxxxxxxxxx>

The 03.04.28 at 21:17, Carlos E. R. wrote:


> I use Suse 8.1. I had to recompile the packaged balsa, because it is
> unable to send email. But my compiled version is unable to launch any
> application, like acrobat or xpdf to see an attached file.pdf on an email,
> it freezes. This behavior happens in both balsa-1.4.2 and 2.0.6 (the
> later is for gtk2). I don't remember if it happened with the suse packaged
> version, 1.2.4.

In the download area of http://balsa.gnome.org I read:

|> Please note also that pspell distributed with RH8.0 makes balsa hang on
|> fork() call, i.e. when any external program is to be forked from balsa.
|> The solutionis to remove -lc from dependency_libs in
|> /usr/lib/libpspell.la.

I don't really understand what the above means. Anyway, the file
/usr/lib/libpspell.la has:

dependency_libs=' /usr/lib/libstdc++.la -lm -lgcc_s -lc -lgcc_s -lm -lgcc_s -lc -lgcc_s /usr/lib/libltdl.la -ldl -L/usr/lib /usr/lib/libpspell-modules.la'

I changed that to:

dependency_libs=' /usr/lib/libstdc++.la -lc -lgcc_s -lc -lgcc_s -lm -lgcc_s -lgcc_s /usr/lib/libltdl.la -ldl -L/usr/lib /usr/lib/libpspell-modules.la'

And run ldconfig - but as I say, I have no idea if that is the correct
way. I run configure, make, test balsa... keeps hanging as soon as it
calls any external viewer. So I undo the above.

I check the archive for the mail list of balsa, and I see some mention of
it having to do with threads and the order of linking libc... well, I
leave the details for the experts. So I run again configure with
"--disable-threads", and this time it works.

I don't know what penalty I'll get for that, but I'm happier :-)

--
Cheers,
Carlos Robinson



< Previous Next >
This Thread
  • No further messages