Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] foobillard (again)
  • From: jalal <the_jalal@xxxxxxxxxxx>
  • Date: Tue, 06 May 2003 15:41:34 +0200
  • Message-id: <3EB7BB8E.2050609@xxxxxxxxxxx>
Anders Johansson wrote:
On Tue, 2003-05-06 at 06:33, growbynet@xxxxxxxxxx wrote:

Trying to update foobillard from version 2.4 (goes with suse 8.2) to 2.6, but got error that says "libglcore.so1 is missing". Any fix, please? AFAIK libglcore.so1 must be installed with NVidia 3d drivers, I have those drivers installed, but no libglcore.so1


What gave you that error? When you tried to install the rpm? Just
install it "--nodeps".

rpm doesn't look at the file system when it looks for files, it only
looks in its database for rpms that "provide" the files. Since the
nvidia installer thing isn't an rpm, there is no rpm that "provides"
those libGL* files. What's needed is a "meta rpm" that doesn't actually
contain anything, except for those database entries

For the nonce, --nodeps will see it through.

If you really don't have the file libGLcore.so.1 on your file system,
reinstall the driver, because it should be there.


I only have 'libGLcore.a', no sign of a '.so' file anywhere, and I searched the SuSE 8.0 DVD, couldn't find it... does it only come with the nVIdia drivers?

When (attempting) installation from source, it looks for files with functions like:
'glGenProgramsNV" which looks suspiciously like an NVidia sort of suffix.

Maybe foobilliard will only run on nVidia hardware, is that possible?



--

GPG fingerprint = 3D45 5509 D380 26A4 523E A9D8 A66A 5F38 CA43 BB0E



< Previous Next >