Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] foobillard (again)
  • From: Ben Rosenberg <ben@xxxxxxxxx>
  • Date: Mon, 5 May 2003 23:13:48 -0700
  • Message-id: <20030506061348.GD18253@xxxxxxxxx>
* John (yonaton@xxxxxxx) [030505 23:05]:
->-----BEGIN PGP SIGNED MESSAGE-----
->Hash: SHA1
->
->On Monday 05 May 2003 23:33, growbynet@xxxxxxxxxx wrote:
->> Trying to update foobillard from version 2.4 (goes with suse 8.2) to 2.6,
->> but got error that says "libglcore.so1 is missing". Any fix, please? AFAIK
->> libglcore.so1 must be installed with NVidia 3d drivers, I have those
->> drivers installed, but no libglcore.so1
->
-> 8.2 has libGLcore.so.1, except that it's named libGLcore.so.1.4363 (or
->something like that...it'll have theversion number of the nvidia drivers on
->the end, like the 4363 is above, it's what I just installed). I just don't
->know what to do to make an rpm that uses the standard name libGLcore.so.1
->find what SuSE has named it, since I ran into the same problem with some
->other app I was trying to install and had the same exact thing come up.
-> Open up the search thing from the main menu, and look for libglcore*, and
->almost instantly you'll see two things pop up and where they are. One of them
->*is* named libGLcore.so.1, but it's linked to libGLcore.so.1.4363<whatever>.
->Hopefully someone will know what to do to workaround this name thing.

cd into the directory containing "libGLcore.so.1.4363" and make a
softlink as to it.

ln -s libGLcore.so.1.4363 libGLcore.so.1

Then run ldconfig. Your app should then be quite happy to use the nVidia
GLX lib.

--
Ben Rosenberg ---===---===---===--- mailto:ben@xxxxxxxxx
Tell me what you believe..
I'll tell you what you should see.

< Previous Next >
References