Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] can not connect to internet ,or, it just connects as root ,or, /etc/resolv.conf is missing (error-KPPP)
  • From: Franklin Maurer <nebbish@xxxxxxxxxxx>
  • Date: 22 Nov 2002 12:40:18 -0500
  • Message-id: <1037986818.2082.12.camel@xxxxxxxxxxx>
On Fri, 2002-11-22 at 07:02, Adagilson B B da Silva wrote:
> thanks for replying
> yesterday i use "chmod" to change permissions to /etc/resolv.conf. I
> think it's OK.
> But when Kppp was open and put to connect a message appeared to me:
> "something like can't open lock file"
> What's now?
> a.
>
--------------------------------------------------------------------------
Did you try setting the set uid bit, for pppd? /usr/sbin/pppd . sorry i
don't know the command to do that, i had to go into konqueror as root,
right click properties, permissions, and check the box for set uid, user
level..

See if that helps.



i also noticed i have the set uid bit set on kppp. i think it's
opt/kde3/bin/kppp. So try that too if it doesn't work after setting it
for pppd.

If those too don't work, I noticed in the kppp setup, there is also a
checkbox to use lock file, did you try to uncheck it? mine is checked,
not sure what it does/why its checked.

Since you are using kppp, there is a known flaw/bug/problem. you need to
copy and then rename /etc/ppp/peers/ppp to /etc/ppp/peers/kppp,
basically it has one line ...
plugin passwordfd.so , so you could just touch ...peers/kppp and add the
line, but since I used konqueror i did the rename copy drill.

There is also kinternet and wvdial, which should work for you. If you
need access now use them If not will try and get it working.


--
Franklin Maurer <nebbish@xxxxxxxxxxx>


< Previous Next >
Follow Ups