Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] Managed to get APT-GET installed
  • From: Thibaut Cousin <cousin@xxxxxxxx>
  • Date: Fri, 8 Nov 2002 09:03:33 +0100
  • Message-id: <200211080903.33617.cousin@xxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Le Jeudi 7 Novembre 2002 19:25, Bill Parker a écrit :
> > What is the content of your file /etc/apt/sources.list?
>
> Here it is:
>
> #
> # Get the latest information about the contents of the sources.list file
> # from http://linux01.gwdg.de/apt4rpm
> #
> # The line rpm-src can be uncommented in case you're interested in
> downloading # source packages (rpms)
>
> #
> # SuSE-7.3
> #
> # rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/7.3-i386 extra
> update kde xfree86 mozilla security gnome2 gnome
> # rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt/ SuSE/7.3-i386 extra
> update kde xfree86 mozilla security
>
> #
> # SuSE-8.0
> #
> rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/8.0-i386 update-prpm
> security-prpm
> rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/8.0-i386 usr-local-bin
> funktronics packman-i386 packman-noarch update kde gnome gnome2 mozilla
> extra security
>
> # rpm-src ftp://ftp.gwdg.de/pub/linux/suse/apt
> SuSE/8.0-i386 usr-local-bin funktronics packman-i386 packman-noarch
> update kde gnome gnome2 mozilla extra security

I don't see the "base" directory in the list. Add it after "security" on the
same line.
Just be careful: it may try to make a massive download. If you don't want
this, use "apt-get install <mypackage>" instead of the big "apt-get
dist-upgrade". If you have the bandwidth, you can do it. Here is the
explanation.
When SuSE puts the RPM on their FTP site, they recompile them. I don't know
why, as they don't include updates for consistency reasons. Because of that,
the release number is higher on FTP that on the CDs (for example, version
1.2-34 on the CD, 1.2-41 on FTP).
Because of that, Apt sees that all RPM packages on FTP are more recent and
downloads everything!

If you're using Synaptic, you can't avoid this massive download. Then I
suggest using Apt:

apt-get update
apt-get install webalizer

That's it. Please let us know the result.

- --
Thibaut Cousin
E-mail : cousin@xxxxxxxx
Web : http://clrwww.in2p3.fr
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE9y2/Vv1vqsTa1E4oRApUlAKCrDKN0/QDTUc4VcUzudfT3ABr+4QCdHO9H
JdTOva9vf/zbA21r41dp7i8=
=KSVG
-----END PGP SIGNATURE-----


< Previous Next >
This Thread
References