Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] What's up with ifup in SuSE 8.1
  • From: Jason Joines <joines@xxxxxxxxxxxxxxx>
  • Date: Wed, 06 Nov 2002 09:36:46 -0600
  • Message-id: <3DC9370E.1090201@xxxxxxxxxxxxxxx>
Mads Martin Joergensen wrote:

* Jason Joines <joines@xxxxxxxxxxxxxxx> [Nov 06. 2002 00:01]:

I have a 3c905B NIC. I've had both SuSE 8.0 and United Linux Beta 3 on it and both ran just fine. Today I wiped out UL to try SuSE 8.1. I did a network install so the NIC was still working and the install all seemed to go fine.

However, on the first reboot and then later when trying to manually run the network script I get the errrors:
lo ifup: Could not get a valid interface name: -> skipped
eth0 ifup: Could not get a valid interface name: -> skipped

If I try to run "ifup eth0", "ifup lo", manually, I get the same error. ifcfg-eth0 and ifcfg-lo both exist in /etc/sysconfig/network and look just fine.

If I configure and bring either up using ifconfig, they work fine.
If I manually run dhcpcd on eth0, it works just fine.

What's up with ifup?


Is the module you need for your eth0 interface correctly configured in
/etc/modules.conf?

What does the line with eth0 say?



I believe it's correct.
It says: alias eth0 3c59x
That's what the install put in.

I tried: alias eth0 3c90x

Neither works with ifup.

Both work if I manually load them and use dhcpcd or ifcfg.


Jason
===========


< Previous Next >