Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
RE: [SLE] HELP! Uninstalled CUPS and can't boot into KDE
  • From: KMcLauchlan@xxxxxxxxxxxxxxxxx
  • Date: Tue, 5 Nov 2002 14:22:10 -0500
  • Message-id: <918C70B01822D411A87400B0D0204DFF01C19B51@xxxxxxxxxxxxxxxxxxxxxxx>


> -----Original Message-----
> From: Thibaut Cousin [mailto:cousin@xxxxxxxx]
> Sent: Tuesday, November 05, 2002 1:25 PM
> To: Suse
> Subject: Re: [SLE] HELP! Uninstalled CUPS and can't boot into KDE
>
>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Le Mardi 5 Novembre 2002 19:05, Tom Nielsen a écrit :
[ Thibault replied to Tom, who had used Synaptic to uninstall
CUPS and had thereby unintentionally blown away much of his X stuff ...]

> > Also, when I try to open YAST2, I get: cannot connect to X
> server :0.0
> > (and I try as root).
>
> Two things:
>
> - - For the last message, type "xhost +" (dirty but
> straightforward) and try
> again to launch something. Does it change anything? Otherwise
> you can launch
> YaST2 in text mode.
[...]
> I think the following thing happened to you. You removed
> CUPS. As many
> packages depend on a printing system, so Synaptic removed
> them as well. After
> that, you installed LPRng but all these other packages were
> not reinstalled
> because LPRng itself doesn't depend on them.
> To give you an idea, here is a short list of what RPM needs
> to remove if I
> try to uninstall CUPS on my system: wine, samba-client,
> ghostscript-library,
> yast2-printer, kdebase3-samba, kdegraphics3-postscript...
> As you can, it removes parts of YaST2, parts of KDE, etc.
>
> Synaptic (or Apt) is a good software to INSTALL things and
> taking care of
> the dependencies at the same time. But it is extremely bad
> for removing
> things, especially fundamental packages. In short: this tool
> is for experts
> only if you want to do anything else than installing.
> If you can, run YaST2 in text mode and lauch the package
> manager. It should
> complain about broken dependencies and reinstall everything important.

I ran Synaptic for the very first time a few weeks ago,
to update some little app (I forget which one), and it
worked fine. So, based on that success, I let Synaptic
go nuts and do a major update of whatever it could find
on my SuSE 8.0 system.

The result was the same as what Tom reported. KDM/GDM were
gone, and I had WindowMaker loading directly, with the
login screen being an "embossed"-looking white-on-white
image of the lizard in the middle of the screen,
and then into WM with no option to choose K or any
other desktop/window manager.

The WM-specific apps, and a few others were working. Many/most
were failing with the same message about "can't find display :0.0".

SUX had no effect.

Booting as Root did not materially change anything.

Using "xhost +" did not make any more apps available to
either my regular self or to root.

By the way, I hope "xhost +" dies (turns off) when you re-boot... :-)

Anyway, my point is that I asked Synaptic to update.
At no time did I invoke an explicit uninstall. Yet
the result was similar to what Tom got. My predicament
would make sense if I had uninstalled something (well,
it would NOW that you've explained the death and
destruction that apt dishes out, when uninstalling
just one package... ), but I seem to have the same
symptoms without having tried to uninstall -- just update.

Hmmm.

/kevin
< Previous Next >
Follow Ups